blob: 9befc51b503c4bee3cb2c29ba5d6fc10c12cc92e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
12SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
13 file://xcbincludedir.patch \
14 file://disable-check.patch \
Brad Bishop19323692019-04-05 15:28:33 -040015 "
16
17SRC_URI[md5sum] = "f33cdfc67346f7217a9326c0d8679975"
18SRC_URI[sha256sum] = "a89fb7af7a11f43d2ce84a844a4b38df688c092bf4b67683aef179cdf2a647c4"
19
20BBCLASSEXTEND = "native nativesdk"
21
22DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp"
23
24PACKAGES_DYNAMIC = "^libxcb-.*"
25
26FILES_${PN} = "${libdir}/libxcb.so.*"
27
Brad Bishop6dbb3162019-11-25 09:41:34 -050028inherit autotools pkgconfig features_check
Brad Bishop19323692019-04-05 15:28:33 -040029
30# The libxau and others requires x11 in DISTRO_FEATURES
31REQUIRED_DISTRO_FEATURES = "x11"
Brad Bishop19323692019-04-05 15:28:33 -040032
33export PYTHON = "python3"
34
35python populate_packages_prepend () {
36 do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
37}