blob: cc7a7e78e2fec5f982d6ecc4d4db413018884b6b [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "GStreamer examples (including gtk-play, gst-play)"
2LICENSE = "LGPL-2.0+"
3LIC_FILES_CHKSUM = "file://playback/player/gtk/gtk-play.c;beginline=1;endline=20;md5=f8c72dae3d36823ec716a9ebcae593b9"
4
5DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gtk+3 glib-2.0-native"
6
Brad Bishop19323692019-04-05 15:28:33 -04007SRC_URI = "git://gitlab.freedesktop.org/gstreamer/gst-examples.git;protocol=https \
Brad Bishop316dfdd2018-06-25 12:45:53 -04008 file://0001-Make-player-examples-installable.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -04009 file://gst-player.desktop \
10 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040011
Brad Bishop15ae2502019-06-18 21:44:24 -040012SRCREV = "d953c127c1146b50d5676618299933950685dcd7"
Brad Bishop316dfdd2018-06-25 12:45:53 -040013
14S = "${WORKDIR}/git"
15
Brad Bishop6dbb3162019-11-25 09:41:34 -050016inherit meson pkgconfig features_check
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
18
19ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
20
21do_install_append() {
22 install -m 0644 -D ${WORKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop
23}
24
25RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback"
26RRECOMMENDS_${PN} = "gstreamer1.0-plugins-base-meta \
27 gstreamer1.0-plugins-good-meta \
28 gstreamer1.0-plugins-bad-meta \
29 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-libav", "", d)} \
30 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}"
31RPROVIDES_${PN} += "gst-player gst-player-bin"