Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Midnight Commander is an ncurses based file manager" |
| 2 | HOMEPAGE = "http://www.midnight-commander.org/" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2" |
| 5 | SECTION = "console/utils" |
| 6 | DEPENDS = "ncurses glib-2.0 util-linux" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | RDEPENDS_${PN} = "ncurses-terminfo-base" |
| 8 | RRECOMMENDS_${PN} = "ncurses-terminfo" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \ |
| 11 | file://0001-mc-replace-perl-w-with-use-warnings.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | file://nomandate.patch \ |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 13 | file://0001-Ticket-4070-misc-Makefile.am-install-mc.lib-only-onc.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | " |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 15 | SRC_URI[md5sum] = "2621de1fa9058a9c41a4248becc969f9" |
| 16 | SRC_URI[sha256sum] = "cfcc4d0546d0c3a88645a8bf71612ed36647ea3264d973b1f28183a0c84bae34" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | |
| 18 | inherit autotools gettext pkgconfig |
| 19 | |
| 20 | # |
| 21 | # Both Samba (smb) and sftp require package delivered from meta-openembedded |
| 22 | # |
| 23 | PACKAGECONFIG ??= "" |
| 24 | PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba," |
| 25 | PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2," |
| 26 | |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 27 | EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-configure-args" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | |
| 29 | CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'" |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 30 | CACHED_CONFIGUREVARS += "ac_cv_path_PYTHON='/usr/bin/env python'" |
| 31 | CACHED_CONFIGUREVARS += "ac_cv_path_GREP='/usr/bin/env grep'" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | CACHED_CONFIGUREVARS += "mc_cv_have_zipinfo=yes" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 33 | |
| 34 | do_install_append () { |
| 35 | sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/* |
| 36 | |
| 37 | rm ${D}${libexecdir}/mc/extfs.d/s3+ ${D}${libexecdir}/mc/extfs.d/uc1541 |
| 38 | } |
| 39 | |
| 40 | PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish" |
| 41 | |
| 42 | SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts" |
| 43 | FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \ |
| 44 | ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \ |
| 45 | ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \ |
| 46 | ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \ |
| 47 | ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \ |
| 48 | ${libexecdir}/mc/extfs.d/uzip" |
| 49 | RDEPENDS_${BPN}-helpers-perl = "perl" |
| 50 | |
| 51 | SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts" |
| 52 | FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*" |
| 53 | |
| 54 | SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts" |
| 55 | FILES_${BPN}-fish = "${libexecdir}/mc/fish" |