blob: 26c5c048267f6a0c148e38ceff70164ff8052369 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "OpenGL (ES) 2.0 benchmark"
2DESCRIPTION = "glmark2 is a benchmark for OpenGL (ES) 2.0. \
3It uses only the subset of the OpenGL 2.0 API that is compatible with OpenGL ES 2.0."
4HOMEPAGE = "https://launchpad.net/glmark2"
5BUGTRACKER = "https://bugs.launchpad.net/glmark2"
6
7LICENSE = "GPLv3+ & SGIv1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
9 file://COPYING.SGI;beginline=5;md5=269cdab4af6748677acce51d9aa13552"
10
11DEPENDS = "libpng12 jpeg"
12
13PV = "2014.03+${SRCPV}"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015SRC_URI = " \
16 git://github.com/glmark2/glmark2.git;protocol=https \
17 file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \
18 file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch \
19 file://Fix-configure-for-sqrt-check.patch \
20"
21SRCREV = "f413c5b423250b4fde8f95639ad368d5b02c5b9b"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050022
23S = "${WORKDIR}/git"
24
25inherit waf pkgconfig
26
27PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gl x11-gles2', '', d)} \
28 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gl wayland-gles2', '', d)} \
29 drm-gl drm-gles2"
30
Patrick Williamsddad1a12017-02-23 20:36:32 -060031# Enable C++11 features
32CXXFLAGS += "-std=c++11"
33
Patrick Williamsb48b7b42016-08-17 15:04:38 -050034PACKAGECONFIG[x11-gl] = ",,virtual/libgl virtual/libx11"
35PACKAGECONFIG[x11-gles2] = ",,virtual/libgles2 virtual/libx11"
36PACKAGECONFIG[drm-gl] = ",,virtual/libgl libdrm"
37PACKAGECONFIG[drm-gles2] = ",,virtual/libgles2 libdrm"
38PACKAGECONFIG[wayland-gl] = ",,virtual/libgl wayland"
39PACKAGECONFIG[wayland-gles2] = ",,virtual/libgles2 wayland"
40
41python __anonymous() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050042 packageconfig = (d.getVar("PACKAGECONFIG") or "").split()
Patrick Williamsb48b7b42016-08-17 15:04:38 -050043 flavors = []
44 if "x11-gles2" in packageconfig:
45 flavors.append("x11-glesv2")
46 if "x11-gl" in packageconfig:
47 flavors.append("x11-gl")
48 if "wayland-gles2" in packageconfig:
49 flavors.append("wayland-glesv2")
50 if "wayland-gl" in packageconfig:
51 flavors.append("wayland-gl")
52 if "drm-gles2" in packageconfig:
53 flavors.append("drm-glesv2")
54 if "drm-gl" in packageconfig:
55 flavors.append("drm-gl")
56 if flavors:
57 d.appendVar("EXTRA_OECONF", " --with-flavors=%s" % ",".join(flavors))
58}
Patrick Williamsddad1a12017-02-23 20:36:32 -060059