blob: 67ffbc67ce066847d508dfe2a5441f39ca858f17 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "7-zip is a commandline utility handling 7z archives."
2HOMEPAGE = "http://www.7-zip.org/"
3LICENSE = "LGPL-2.1+ & unRAR"
Patrick Williamsddad1a12017-02-23 20:36:32 -06004LIC_FILES_CHKSUM = "file://DOC/copying.txt;md5=4fbd65380cdd255951079008b364516c \
5 file://DOC/unRarLicense.txt;md5=9c87ddde469ef94aed153b0951d088de \
6 file://DOC/License.txt;md5=879598edf1f54dddb6930d7581357f8b"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
8SRC_URI = "http://downloads.sourceforge.net/p7zip/p7zip/${PV}/p7zip_${PV}_src_all.tar.bz2 \
9 file://do_not_override_compiler_and_do_not_strip.patch"
Patrick Williamsddad1a12017-02-23 20:36:32 -060010
11SRC_URI[md5sum] = "a0128d661cfe7cc8c121e73519c54fbf"
12SRC_URI[sha256sum] = "5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050013
14S = "${WORKDIR}/${BPN}_${PV}"
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m 0755 ${S}/bin/* ${D}${bindir}
19}
20
21# all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx
22EXTRA_OEMAKE_class-native = "all3"
23
24do_install_class-native() {
25 install -d ${D}${bindir}
26 install -d ${D}${bindir}/Codecs
27 install -m 0755 ${S}/bin/7* ${D}${bindir}
28 install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs
29
30 # Create a shell script wrapper to execute next to 7z.so
31 mv ${D}${bindir}/7z ${D}${bindir}/7z.bin
Patrick Williamsddad1a12017-02-23 20:36:32 -060032 cat > ${D}${bindir}/7z << 'EOF'
33#!/bin/sh
34exec "$(dirname "$0")"/7z.bin "$@"
35EOF
Patrick Williamsb48b7b42016-08-17 15:04:38 -050036 chmod 0755 ${D}${bindir}/7z
37}
38
Brad Bishop6e60e8b2018-02-01 10:27:11 -050039BBCLASSEXTEND = "native"