blob: cc30541844b2678b224b35e8f72373cc8604d8d0 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Common X11 scripts and support files"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005PR = "r9"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006
7# we are using a gpe-style Makefile
8inherit gpe
9
10SRC_URI[md5sum] = "82f2f84cd96610e8f7b92c700cd31c14"
11SRC_URI[sha256sum] = "cd04c33418f776b1e13fcc7af3d6bd0c7cccd03fbabd7dbcd97f88166cc34210"
12
13SRC_URI_append = " \
14 file://0001-COPYING-add-GPLv2-license-file.patch \
15 file://0002-add-setdpi-Xinit.d-script.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016 file://0006-add-support-for-etc-X11-xserver-system.patch \
17 file://0007-use-own-functions-file-instead-etc-init.d-functions.patch \
18 file://0008-xserver-common-add-dpi-and-nocursor-params-for-gta01.patch \
19 file://0009-xserver-common-add-support-for-n900-alias-nokia_rx-5.patch \
20 file://0010-xserver-common-add-support-for-nexus-S-alias-herring.patch \
21 file://0011-xserver-common-add-support-for-nexus-one-alias-mahim.patch \
22 file://0012-xserver-common-add-support-for-gta04-alias-OpenPhoen.patch \
23 file://0013-xserver-common-add-support-for-tuna-alias-Galaxy-Nex.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024 file://0015-xserver-common-disable-TCP-connections.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025 file://0001-Don-t-install-Xsession-or-Xserver.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026"
27
28do_install_append() {
29 sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
30 # Rename all Xsession files not ending with .sh
31 # Unfortunatelly when xinput-calibrator was moved to oe-core
32 # its Xsession file got name 30xinput_calibrate.sh and ls -X sorts it
33 # last, not respecting numbers for sorting them
34 for i in ${D}/${sysconfdir}/X11/Xsession.d/*; do
35 echo $i | grep '.sh$' || mv $i $i.sh
36 done
37}
38
39RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo fbset xinput-calibrator"
40
41RCONFLICTS_${PN} = "xserver-kdrive-common x11-common"
42RREPLACES_${PN} = "xserver-kdrive-common x11-common"
43