blob: b85ba8a02880fcb148bb3f6bb61be2f9f17c7d51 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
9LICENSE = "GPLv2 & LGPLv2.1"
10LIC_FILES_CHKSUM = " \
11 file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
12 file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
13"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015DEPENDS = "libsamplerate0 libsndfile1 readline"
Patrick Williamsddad1a12017-02-23 20:36:32 -060016
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017SRC_URI = "git://github.com/jackaudio/jack2.git \
18 file://0001-typecast-input-parameter-to-int-for-abs.patch \
19 "
20SRCREV = "2d1d323505585d406a7e64fb932953baefc5945e"
Patrick Williamsddad1a12017-02-23 20:36:32 -060021PV = "1.9.10+git${SRCPV}"
22S = "${WORKDIR}/git"
23
24inherit waf pkgconfig
25
26PACKAGECONFIG ??= "alsa"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
28PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
Patrick Williamsddad1a12017-02-23 20:36:32 -060029
30# portaudio is for windows builds only
31EXTRA_OECONF = "--portaudio=no"
32
33PACKAGES =+ "libjack jack-server jack-utils"
34
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035RDEPENDS_jack-dev_remove = "${PN} (= ${EXTENDPKGV})"
36
Patrick Williamsddad1a12017-02-23 20:36:32 -060037FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
38FILES_jack-server = "${bindir}/jackd"
39FILES_jack-utils = "${bindir}/*"
40FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/* "