blob: 4c4ae66d62d83302742107a39a5ddd3d5130abf0 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Firmware testsuite"
2DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
4
5LICENSE = "GPLv2+"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008PV = "17.03.00"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05009
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010SRCREV = "e3e9d1442b4cc70f5b30199f584cec8e25aeaad4"
11SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git \
12 file://0001-ignore-constant-logical-operand-warning-with-clang.patch \
13 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014
15S = "${WORKDIR}/git"
16
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019DEPENDS = "libpcre json-c glib-2.0 dtc"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021inherit autotools pkgconfig
22
23CFLAGS += "-I${STAGING_INCDIR}/json-c -Wno-error=unknown-pragmas"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024
25FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
26FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
27FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
28FILES_${PN}-dbg += "${libdir}/fwts/.debug"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029
30TOOLCHAIN = "gcc"
31