blob: 4bba76c3ba9fd0207216e7cad88c198e8be2501b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# This class is used to help the alternatives system which is useful when
2# multiple sources provide same command. You can use update-alternatives
3# command directly in your recipe, but in most cases this class simplifies
4# that job.
5#
6# To use this class a number of variables should be defined:
7#
8# List all of the alternatives needed by a package:
9# ALTERNATIVE_<pkg> = "name1 name2 name3 ..."
10#
11# i.e. ALTERNATIVE_busybox = "sh sed test bracket"
12#
13# The pathname of the link
14# ALTERNATIVE_LINK_NAME[name] = "target"
15#
16# This is the name of the binary once it's been installed onto the runtime.
17# This name is global to all split packages in this recipe, and should match
18# other recipes with the same functionality.
19# i.e. ALTERNATIVE_LINK_NAME[bracket] = "/usr/bin/["
20#
21# NOTE: If ALTERNATIVE_LINK_NAME is not defined, it defaults to ${bindir}/name
22#
23# The default link to create for all targets
24# ALTERNATIVE_TARGET = "target"
25#
26# This is useful in a multicall binary case
27# i.e. ALTERNATIVE_TARGET = "/bin/busybox"
28#
29# A non-default link to create for a target
30# ALTERNATIVE_TARGET[name] = "target"
31#
32# This is the name of the binary as it's been install by do_install
33# i.e. ALTERNATIVE_TARGET[sh] = "/bin/bash"
34#
35# A package specific link for a target
36# ALTERNATIVE_TARGET_<pkg>[name] = "target"
37#
38# This is useful when a recipe provides multiple alternatives for the
39# same item.
40#
41# NOTE: If ALTERNATIVE_TARGET is not defined, it will inherit the value
42# from ALTERNATIVE_LINK_NAME.
43#
44# NOTE: If the ALTERNATIVE_LINK_NAME and ALTERNATIVE_TARGET are the same,
45# ALTERNATIVE_TARGET will have '.{BPN}' appended to it. If the file
46# referenced has not been renamed, it will also be renamed. (This avoids
47# the need to rename alternative files in the do_install step, but still
48# supports it if necessary for some reason.)
49#
50# The default priority for any alternatives
51# ALTERNATIVE_PRIORITY = "priority"
52#
53# i.e. default is ALTERNATIVE_PRIORITY = "10"
54#
55# The non-default priority for a specific target
56# ALTERNATIVE_PRIORITY[name] = "priority"
57#
58# The package priority for a specific target
59# ALTERNATIVE_PRIORITY_<pkg>[name] = "priority"
60
61ALTERNATIVE_PRIORITY = "10"
62
63# We need special processing for vardeps because it can not work on
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050064# modified flag values. So we aggregate the flags into a new variable
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065# and include that vairable in the set.
66UPDALTVARS = "ALTERNATIVE ALTERNATIVE_LINK_NAME ALTERNATIVE_TARGET ALTERNATIVE_PRIORITY"
67
Brad Bishop6e60e8b2018-02-01 10:27:11 -050068PACKAGE_WRITE_DEPS += "virtual/update-alternatives-native"
69
Patrick Williamsc124f4f2015-09-15 14:41:29 -050070def gen_updatealternativesvardeps(d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050071 pkgs = (d.getVar("PACKAGES") or "").split()
72 vars = (d.getVar("UPDALTVARS") or "").split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050073
74 # First compute them for non_pkg versions
75 for v in vars:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060076 for flag in sorted((d.getVarFlags(v) or {}).keys()):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050077 if flag == "doc" or flag == "vardeps" or flag == "vardepsexp":
78 continue
79 d.appendVar('%s_VARDEPS' % (v), ' %s:%s' % (flag, d.getVarFlag(v, flag, False)))
80
81 for p in pkgs:
82 for v in vars:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060083 for flag in sorted((d.getVarFlags("%s_%s" % (v,p)) or {}).keys()):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084 if flag == "doc" or flag == "vardeps" or flag == "vardepsexp":
85 continue
86 d.appendVar('%s_VARDEPS_%s' % (v,p), ' %s:%s' % (flag, d.getVarFlag('%s_%s' % (v,p), flag, False)))
87
88def ua_extend_depends(d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050089 if not 'virtual/update-alternatives' in d.getVar('PROVIDES'):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050090 d.appendVar('DEPENDS', ' virtual/${MLPREFIX}update-alternatives')
91
92python __anonymous() {
93 # Update Alternatives only works on target packages...
94 if bb.data.inherits_class('native', d) or \
95 bb.data.inherits_class('cross', d) or bb.data.inherits_class('crosssdk', d) or \
96 bb.data.inherits_class('cross-canadian', d):
97 return
98
Brad Bishop6e60e8b2018-02-01 10:27:11 -050099 # Disable when targeting mingw32 (no target support)
100 if d.getVar("TARGET_OS") == "mingw32":
101 return
102
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500103 # compute special vardeps
104 gen_updatealternativesvardeps(d)
105
106 # extend the depends to include virtual/update-alternatives
107 ua_extend_depends(d)
108}
109
110def gen_updatealternativesvars(d):
111 ret = []
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500112 pkgs = (d.getVar("PACKAGES") or "").split()
113 vars = (d.getVar("UPDALTVARS") or "").split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500114
115 for v in vars:
116 ret.append(v + "_VARDEPS")
117
118 for p in pkgs:
119 for v in vars:
120 ret.append(v + "_" + p)
121 ret.append(v + "_VARDEPS_" + p)
122 return " ".join(ret)
123
124# Now the new stuff, we use a custom function to generate the right values
125populate_packages[vardeps] += "${UPDALTVARS} ${@gen_updatealternativesvars(d)}"
126
127# We need to do the rename after the image creation step, but before
128# the split and strip steps.. packagecopy seems to be the earliest reasonable
129# place.
130python perform_packagecopy_append () {
131 # Check for deprecated usage...
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500132 pn = d.getVar('BPN')
133 if d.getVar('ALTERNATIVE_LINKS') != None:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500134 bb.fatal('%s: Use of ALTERNATIVE_LINKS/ALTERNATIVE_PATH/ALTERNATIVE_NAME is no longer supported, please convert to the updated syntax, see update-alternatives.bbclass for more info.' % pn)
135
136 # Do actual update alternatives processing
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500137 pkgdest = d.getVar('PKGD')
138 for pkg in (d.getVar('PACKAGES') or "").split():
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500139 # If the src == dest, we know we need to rename the dest by appending ${BPN}
140 link_rename = {}
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500141 for alt_name in (d.getVar('ALTERNATIVE_%s' % pkg) or "").split():
142 alt_link = d.getVarFlag('ALTERNATIVE_LINK_NAME', alt_name)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500143 if not alt_link:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500144 alt_link = "%s/%s" % (d.getVar('bindir'), alt_name)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500145 d.setVarFlag('ALTERNATIVE_LINK_NAME', alt_name, alt_link)
146
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500147 alt_target = d.getVarFlag('ALTERNATIVE_TARGET_%s' % pkg, alt_name) or d.getVarFlag('ALTERNATIVE_TARGET', alt_name)
148 alt_target = alt_target or d.getVar('ALTERNATIVE_TARGET_%s' % pkg) or d.getVar('ALTERNATIVE_TARGET') or alt_link
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500149 # Sometimes alt_target is specified as relative to the link name.
150 alt_target = os.path.join(os.path.dirname(alt_link), alt_target)
151
152 # If the link and target are the same name, we need to rename the target.
153 if alt_link == alt_target:
154 src = '%s/%s' % (pkgdest, alt_target)
155 alt_target_rename = '%s.%s' % (alt_target, pn)
156 dest = '%s/%s' % (pkgdest, alt_target_rename)
157 if os.path.lexists(dest):
158 bb.note('%s: Already renamed: %s' % (pn, alt_target_rename))
159 elif os.path.lexists(src):
160 if os.path.islink(src):
161 # Delay rename of links
162 link_rename[alt_target] = alt_target_rename
163 else:
164 bb.note('%s: Rename %s -> %s' % (pn, alt_target, alt_target_rename))
165 os.rename(src, dest)
166 else:
167 bb.warn("%s: alternative target (%s or %s) does not exist, skipping..." % (pn, alt_target, alt_target_rename))
168 continue
169 d.setVarFlag('ALTERNATIVE_TARGET_%s' % pkg, alt_name, alt_target_rename)
170
171 # Process delayed link names
172 # Do these after other renames so we can correct broken links
173 for alt_target in link_rename:
174 src = '%s/%s' % (pkgdest, alt_target)
175 dest = '%s/%s' % (pkgdest, link_rename[alt_target])
176 link = os.readlink(src)
177 link_target = oe.path.realpath(src, pkgdest, True)
178
179 if os.path.lexists(link_target):
180 # Ok, the link_target exists, we can rename
181 bb.note('%s: Rename (link) %s -> %s' % (pn, alt_target, link_rename[alt_target]))
182 os.rename(src, dest)
183 else:
184 # Try to resolve the broken link to link.${BPN}
185 link_maybe = '%s.%s' % (os.readlink(src), pn)
186 if os.path.lexists(os.path.join(os.path.dirname(src), link_maybe)):
187 # Ok, the renamed link target exists.. create a new link, and remove the original
188 bb.note('%s: Creating new link %s -> %s' % (pn, link_rename[alt_target], link_maybe))
189 os.symlink(link_maybe, dest)
190 os.unlink(src)
191 else:
192 bb.warn('%s: Unable to resolve dangling symlink: %s' % (pn, alt_target))
193}
194
195PACKAGESPLITFUNCS_prepend = "populate_packages_updatealternatives "
196
197python populate_packages_updatealternatives () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500198 pn = d.getVar('BPN')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500199
200 # Do actual update alternatives processing
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500201 pkgdest = d.getVar('PKGD')
202 for pkg in (d.getVar('PACKAGES') or "").split():
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500203 # Create post install/removal scripts
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500204 alt_setup_links = "# Begin section update-alternatives\n"
205 alt_remove_links = "# Begin section update-alternatives\n"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500206 for alt_name in (d.getVar('ALTERNATIVE_%s' % pkg) or "").split():
207 alt_link = d.getVarFlag('ALTERNATIVE_LINK_NAME', alt_name)
208 alt_target = d.getVarFlag('ALTERNATIVE_TARGET_%s' % pkg, alt_name) or d.getVarFlag('ALTERNATIVE_TARGET', alt_name)
209 alt_target = alt_target or d.getVar('ALTERNATIVE_TARGET_%s' % pkg) or d.getVar('ALTERNATIVE_TARGET') or alt_link
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500210 # Sometimes alt_target is specified as relative to the link name.
211 alt_target = os.path.join(os.path.dirname(alt_link), alt_target)
212
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500213 alt_priority = d.getVarFlag('ALTERNATIVE_PRIORITY_%s' % pkg, alt_name) or d.getVarFlag('ALTERNATIVE_PRIORITY', alt_name)
214 alt_priority = alt_priority or d.getVar('ALTERNATIVE_PRIORITY_%s' % pkg) or d.getVar('ALTERNATIVE_PRIORITY')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500215
216 # This shouldn't trigger, as it should have been resolved earlier!
217 if alt_link == alt_target:
218 bb.note('alt_link == alt_target: %s == %s -- correcting, this should not happen!' % (alt_link, alt_target))
219 alt_target = '%s.%s' % (alt_target, pn)
220
221 if not os.path.lexists('%s/%s' % (pkgdest, alt_target)):
222 bb.warn('%s: NOT adding alternative provide %s: %s does not exist' % (pn, alt_link, alt_target))
223 continue
224
225 # Default to generate shell script.. eventually we may want to change this...
226 alt_target = os.path.normpath(alt_target)
227
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500228 alt_setup_links += 'update-alternatives --install %s %s %s %s\n' % (alt_link, alt_name, alt_target, alt_priority)
229 alt_remove_links += 'update-alternatives --remove %s %s\n' % (alt_name, alt_target)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500230
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500231 alt_setup_links += "# End section update-alternatives\n"
232 alt_remove_links += "# End section update-alternatives\n"
233
234 if len(alt_setup_links.splitlines()) > 2:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500235 # RDEPENDS setup
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500236 provider = d.getVar('VIRTUAL-RUNTIME_update-alternatives')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500237 if provider:
238 #bb.note('adding runtime requirement for update-alternatives for %s' % pkg)
239 d.appendVar('RDEPENDS_%s' % pkg, ' ' + d.getVar('MLPREFIX', False) + provider)
240
241 bb.note('adding update-alternatives calls to postinst/prerm for %s' % pkg)
242 bb.note('%s' % alt_setup_links)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500243 postinst = d.getVar('pkg_postinst_%s' % pkg) or '#!/bin/sh\n'
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500244 postinst = postinst.splitlines(True)
245 try:
246 index = postinst.index('# Begin section update-rc.d\n')
247 postinst.insert(index, alt_setup_links)
248 except ValueError:
249 postinst.append(alt_setup_links)
250 postinst = ''.join(postinst)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500251 d.setVar('pkg_postinst_%s' % pkg, postinst)
252
253 bb.note('%s' % alt_remove_links)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500254 prerm = d.getVar('pkg_prerm_%s' % pkg) or '#!/bin/sh\n'
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500255 prerm = prerm.splitlines(True)
256 try:
257 index = prerm.index('# End section update-rc.d\n')
258 prerm.insert(index + 1, alt_remove_links)
259 except ValueError:
260 prerm.append(alt_remove_links)
261 prerm = ''.join(prerm)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500262 d.setVar('pkg_prerm_%s' % pkg, prerm)
263}
264
265python package_do_filedeps_append () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500266 pn = d.getVar('BPN')
267 pkgdest = d.getVar('PKGDEST')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500268
269 for pkg in packages.split():
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500270 for alt_name in (d.getVar('ALTERNATIVE_%s' % pkg) or "").split():
271 alt_link = d.getVarFlag('ALTERNATIVE_LINK_NAME', alt_name)
272 alt_target = d.getVarFlag('ALTERNATIVE_TARGET_%s' % pkg, alt_name) or d.getVarFlag('ALTERNATIVE_TARGET', alt_name)
273 alt_target = alt_target or d.getVar('ALTERNATIVE_TARGET_%s' % pkg) or d.getVar('ALTERNATIVE_TARGET') or alt_link
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500274
275 if alt_link == alt_target:
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500276 bb.warn('%s: alt_link == alt_target: %s == %s' % (pn, alt_link, alt_target))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500277 alt_target = '%s.%s' % (alt_target, pn)
278
279 if not os.path.lexists('%s/%s/%s' % (pkgdest, pkg, alt_target)):
280 continue
281
282 # Add file provide
283 trans_target = oe.package.file_translate(alt_target)
284 d.appendVar('FILERPROVIDES_%s_%s' % (trans_target, pkg), " " + alt_link)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500285 if not trans_target in (d.getVar('FILERPROVIDESFLIST_%s' % pkg) or ""):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500286 d.appendVar('FILERPROVIDESFLIST_%s' % pkg, " " + trans_target)
287}
288