blob: 0f551b50f3b18a8391496bc2bb533022b9e6eec5 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001inherit useradd_base
2
3# base-passwd-cross provides the default passwd and group files in the
4# target sysroot, and shadow -native and -sysroot provide the utilities
5# and support files needed to add and modify user and group accounts
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006DEPENDS_append_class-target = " base-files shadow-native shadow-sysroot shadow base-passwd"
7PACKAGE_WRITE_DEPS += "shadow-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
9# This preinstall function can be run in four different contexts:
10#
11# a) Before do_install
12# b) At do_populate_sysroot_setscene when installing from sstate packages
13# c) As the preinst script in the target package at do_rootfs time
14# d) As the preinst script in the target package on device as a package upgrade
15#
16useradd_preinst () {
17OPT=""
18SYSROOT=""
19
20if test "x$D" != "x"; then
21 # Installing into a sysroot
22 SYSROOT="$D"
23 OPT="--root $D"
24
25 # Make sure login.defs is there, this is to make debian package backend work
26 # correctly while doing rootfs.
27 # The problem here is that if /etc/login.defs is treated as a config file for
28 # shadow package, then while performing preinsts for packages that depend on
29 # shadow, there might only be /etc/login.def.dpkg-new there in root filesystem.
30 if [ ! -e $D${sysconfdir}/login.defs -a -e $D${sysconfdir}/login.defs.dpkg-new ]; then
31 cp $D${sysconfdir}/login.defs.dpkg-new $D${sysconfdir}/login.defs
32 fi
33
34 # user/group lookups should match useradd/groupadd --root
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035 export PSEUDO_PASSWD="$SYSROOT"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036fi
37
38# If we're not doing a special SSTATE/SYSROOT install
39# then set the values, otherwise use the environment
40if test "x$UA_SYSROOT" = "x"; then
41 # Installing onto a target
42 # Add groups and users defined only for this package
43 GROUPADD_PARAM="${GROUPADD_PARAM}"
44 USERADD_PARAM="${USERADD_PARAM}"
45 GROUPMEMS_PARAM="${GROUPMEMS_PARAM}"
46fi
47
48# Perform group additions first, since user additions may depend
49# on these groups existing
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050050if test "x`echo $GROUPADD_PARAM | tr -d '[:space:]'`" != "x"; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051 echo "Running groupadd commands..."
52 # Invoke multiple instances of groupadd for parameter lists
53 # separated by ';'
Patrick Williamsc0f7c042017-02-23 20:41:17 -060054 opts=`echo "$GROUPADD_PARAM" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
55 remaining=`echo "$GROUPADD_PARAM" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -050056 while test "x$opts" != "x"; do
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050057 perform_groupadd "$SYSROOT" "$OPT $opts"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050058 if test "x$opts" = "x$remaining"; then
59 break
60 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -060061 opts=`echo "$remaining" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
62 remaining=`echo "$remaining" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -050063 done
64fi
65
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050066if test "x`echo $USERADD_PARAM | tr -d '[:space:]'`" != "x"; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -050067 echo "Running useradd commands..."
68 # Invoke multiple instances of useradd for parameter lists
69 # separated by ';'
Patrick Williamsc0f7c042017-02-23 20:41:17 -060070 opts=`echo "$USERADD_PARAM" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
71 remaining=`echo "$USERADD_PARAM" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -050072 while test "x$opts" != "x"; do
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050073 perform_useradd "$SYSROOT" "$OPT $opts"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050074 if test "x$opts" = "x$remaining"; then
75 break
76 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -060077 opts=`echo "$remaining" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
78 remaining=`echo "$remaining" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -050079 done
80fi
81
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050082if test "x`echo $GROUPMEMS_PARAM | tr -d '[:space:]'`" != "x"; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -050083 echo "Running groupmems commands..."
84 # Invoke multiple instances of groupmems for parameter lists
85 # separated by ';'
Patrick Williamsc0f7c042017-02-23 20:41:17 -060086 opts=`echo "$GROUPMEMS_PARAM" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
87 remaining=`echo "$GROUPMEMS_PARAM" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -050088 while test "x$opts" != "x"; do
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050089 perform_groupmems "$SYSROOT" "$OPT $opts"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050090 if test "x$opts" = "x$remaining"; then
91 break
92 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -060093 opts=`echo "$remaining" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
94 remaining=`echo "$remaining" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -050095 done
96fi
97}
98
99useradd_sysroot () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500100 # Pseudo may (do_prepare_recipe_sysroot) or may not (do_populate_sysroot_setscene) be running
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500101 # at this point so we're explicit about the environment so pseudo can load if
102 # not already present.
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500103 export PSEUDO="${FAKEROOTENV} ${PSEUDO_SYSROOT}${bindir_native}/pseudo"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500104
105 # Explicitly set $D since it isn't set to anything
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500106 # before do_prepare_recipe_sysroot
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500107 D=${STAGING_DIR_TARGET}
108
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500109 # base-passwd's postinst may not have run yet in which case we'll get called later, just exit.
110 # Beware that in some cases we might see the fake pseudo passwd here, in which case we also must
111 # exit.
112 if [ ! -f $D${sysconfdir}/passwd ] ||
113 grep -q this-is-the-pseudo-passwd $D${sysconfdir}/passwd; then
114 exit 0
115 fi
116
117 # It is also possible we may be in a recipe which doesn't have useradd dependencies and hence the
118 # useradd/groupadd tools are unavailable. If there is no dependency, we assume we don't want to
119 # create users in the sysroot
120 if ! command -v useradd; then
121 exit 0
122 fi
123
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500124 # Add groups and users defined for all recipe packages
125 GROUPADD_PARAM="${@get_all_cmd_params(d, 'groupadd')}"
126 USERADD_PARAM="${@get_all_cmd_params(d, 'useradd')}"
127 GROUPMEMS_PARAM="${@get_all_cmd_params(d, 'groupmems')}"
128
129 # Tell the system to use the environment vars
130 UA_SYSROOT=1
131
132 useradd_preinst
133}
134
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500135# The export of PSEUDO in useradd_sysroot() above contains references to
136# ${COMPONENTS_DIR} and ${PSEUDO_LOCALSTATEDIR}. Additionally, the logging
137# shell functions use ${LOGFIFO}. These need to be handled when restoring
138# postinst-useradd-${PN} from the sstate cache.
139EXTRA_STAGING_FIXMES += "COMPONENTS_DIR PSEUDO_LOCALSTATEDIR LOGFIFO"
140
141python useradd_sysroot_sstate () {
142 task = d.getVar("BB_CURRENTTASK")
143 if task == "package_setscene":
144 bb.build.exec_func("useradd_sysroot", d)
145 elif task == "prepare_recipe_sysroot":
146 # Used to update this recipe's own sysroot so the user/groups are available to do_install
147 scriptfile = d.expand("${RECIPE_SYSROOT}${bindir}/postinst-useradd-${PN}")
148 bb.utils.mkdirhier(os.path.dirname(scriptfile))
149 with open(scriptfile, 'w') as script:
150 script.write("#!/bin/sh\n")
151 bb.data.emit_func("useradd_sysroot", script, d)
152 script.write("useradd_sysroot\n")
153 os.chmod(scriptfile, 0o755)
154 bb.build.exec_func("useradd_sysroot", d)
155 elif task == "populate_sysroot":
156 # Used when installed in dependent task sysroots
157 scriptfile = d.expand("${SYSROOT_DESTDIR}${bindir}/postinst-useradd-${PN}")
158 bb.utils.mkdirhier(os.path.dirname(scriptfile))
159 with open(scriptfile, 'w') as script:
160 script.write("#!/bin/sh\n")
161 bb.data.emit_func("useradd_sysroot", script, d)
162 script.write("useradd_sysroot\n")
163 os.chmod(scriptfile, 0o755)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500164}
165
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500166do_prepare_recipe_sysroot[postfuncs] += "${SYSROOTFUNC}"
167SYSROOTFUNC_class-target = "useradd_sysroot_sstate"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600168SYSROOTFUNC = ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500169
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500170SYSROOT_PREPROCESS_FUNCS += "${SYSROOTFUNC}"
171
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600172SSTATEPREINSTFUNCS_append_class-target = " useradd_sysroot_sstate"
173
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500174do_package_setscene[depends] += "${USERADDSETSCENEDEPS}"
175do_populate_sysroot_setscene[depends] += "${USERADDSETSCENEDEPS}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600176USERADDSETSCENEDEPS_class-target = "${MLPREFIX}base-passwd:do_populate_sysroot_setscene pseudo-native:do_populate_sysroot_setscene shadow-native:do_populate_sysroot_setscene ${MLPREFIX}shadow-sysroot:do_populate_sysroot_setscene"
177USERADDSETSCENEDEPS = ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500178
179# Recipe parse-time sanity checks
180def update_useradd_after_parse(d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500181 useradd_packages = d.getVar('USERADD_PACKAGES')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500182
183 if not useradd_packages:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600184 bb.fatal("%s inherits useradd but doesn't set USERADD_PACKAGES" % d.getVar('FILE', False))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500185
186 for pkg in useradd_packages.split():
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500187 if not d.getVar('USERADD_PARAM_%s' % pkg) and not d.getVar('GROUPADD_PARAM_%s' % pkg) and not d.getVar('GROUPMEMS_PARAM_%s' % pkg):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500188 bb.fatal("%s inherits useradd but doesn't set USERADD_PARAM, GROUPADD_PARAM or GROUPMEMS_PARAM for package %s" % (d.getVar('FILE', False), pkg))
189
190python __anonymous() {
191 if not bb.data.inherits_class('nativesdk', d) \
192 and not bb.data.inherits_class('native', d):
193 update_useradd_after_parse(d)
194}
195
196# Return a single [GROUP|USER]ADD_PARAM formatted string which includes the
197# [group|user]add parameters for all USERADD_PACKAGES in this recipe
198def get_all_cmd_params(d, cmd_type):
199 import string
200
201 param_type = cmd_type.upper() + "_PARAM_%s"
202 params = []
203
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500204 useradd_packages = d.getVar('USERADD_PACKAGES') or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500205 for pkg in useradd_packages.split():
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500206 param = d.getVar(param_type % pkg)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500207 if param:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600208 params.append(param.rstrip(" ;"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500209
210 return "; ".join(params)
211
212# Adds the preinst script into generated packages
213fakeroot python populate_packages_prepend () {
214 def update_useradd_package(pkg):
215 bb.debug(1, 'adding user/group calls to preinst for %s' % pkg)
216
217 """
218 useradd preinst is appended here because pkg_preinst may be
219 required to execute on the target. Not doing so may cause
220 useradd preinst to be invoked twice, causing unwanted warnings.
221 """
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500222 preinst = d.getVar('pkg_preinst_%s' % pkg) or d.getVar('pkg_preinst')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500223 if not preinst:
224 preinst = '#!/bin/sh\n'
225 preinst += 'bbnote () {\n\techo "NOTE: $*"\n}\n'
226 preinst += 'bbwarn () {\n\techo "WARNING: $*"\n}\n'
227 preinst += 'bbfatal () {\n\techo "ERROR: $*"\n\texit 1\n}\n'
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500228 preinst += 'perform_groupadd () {\n%s}\n' % d.getVar('perform_groupadd')
229 preinst += 'perform_useradd () {\n%s}\n' % d.getVar('perform_useradd')
230 preinst += 'perform_groupmems () {\n%s}\n' % d.getVar('perform_groupmems')
231 preinst += d.getVar('useradd_preinst')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500232 d.setVar('pkg_preinst_%s' % pkg, preinst)
233
234 # RDEPENDS setup
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500235 rdepends = d.getVar("RDEPENDS_%s" % pkg) or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500236 rdepends += ' ' + d.getVar('MLPREFIX', False) + 'base-passwd'
237 rdepends += ' ' + d.getVar('MLPREFIX', False) + 'shadow'
238 # base-files is where the default /etc/skel is packaged
239 rdepends += ' ' + d.getVar('MLPREFIX', False) + 'base-files'
240 d.setVar("RDEPENDS_%s" % pkg, rdepends)
241
242 # Add the user/group preinstall scripts and RDEPENDS requirements
243 # to packages specified by USERADD_PACKAGES
244 if not bb.data.inherits_class('nativesdk', d) \
245 and not bb.data.inherits_class('native', d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500246 useradd_packages = d.getVar('USERADD_PACKAGES') or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500247 for pkg in useradd_packages.split():
248 update_useradd_package(pkg)
249}
250
251# Use the following to extend the useradd with custom functions
252USERADDEXTENSION ?= ""
253
254inherit ${USERADDEXTENSION}