blob: b5f68951d70007985a0e1321c841f78ca61fa22f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Enables PPP dial-in through a serial connection"
2SECTION = "console/network"
3DEPENDS = "ppp"
4RDEPENDS_${PN} = "ppp"
5PR = "r8"
6LICENSE = "MIT"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
9SRC_URI = "file://host-peer \
10 file://ppp-dialin"
11
12inherit allarch useradd
13
14S = "${WORKDIR}"
15
16do_install() {
17 install -d ${D}${sysconfdir}/ppp/peers
18 install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
19
20 install -d ${D}${sbindir}
21 install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
22}
23
24USERADD_PACKAGES = "${PN}"
25USERADD_PARAM_${PN} = "--system --home /dev/null \
26 --no-create-home --shell ${sbindir}/ppp-dialin \
27 --no-user-group --gid nogroup ppp"