blob: 2ca639294a8e18875b62de6bdd23aa3a00e2e645 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2007 OpenedHand Ltd
3#
4
5SUMMARY = "Host packages for the standalone SDK or external toolchain"
6PR = "r12"
7LICENSE = "MIT"
8
9inherit packagegroup nativesdk
10
11PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
12
13RDEPENDS_${PN} = "\
14 nativesdk-pkgconfig \
15 nativesdk-qemu \
16 nativesdk-qemu-helper \
17 nativesdk-pseudo \
18 nativesdk-unfs3 \
19 nativesdk-opkg \
20 nativesdk-libtool \
21 nativesdk-autoconf \
22 nativesdk-automake \
23 nativesdk-shadow \
24 nativesdk-makedevs \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025 nativesdk-dnf \
26 nativesdk-cmake \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027 nativesdk-postinst-intercept \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060028 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'nativesdk-wayland', '', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029 "
30
31RDEPENDS_${PN}_darwin = "\
32 nativesdk-pkgconfig \
33 nativesdk-opkg \
34 nativesdk-libtool \
35 "