blob: 27d53157db120003b62b9c4beaf0467e60b2719b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Helper utilities needed by the runqemu script"
2LICENSE = "GPLv2"
3RDEPENDS_${PN} = "qemu-native"
4PR = "r1"
5
6LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999"
7
8SRC_URI = "file://tunctl.c"
9
10S = "${WORKDIR}"
11
12inherit native
13
14do_compile() {
15 ${CC} tunctl.c -o tunctl
16}
17
18do_install() {
19 install -d ${D}${bindir}
20 install tunctl ${D}${bindir}/
21}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050022
23RM_WORK_EXCLUDE_ITEMS += "recipe-sysroot-native"
24DEPENDS += "qemu-native"
25addtask addto_recipe_sysroot after do_populate_sysroot before do_build