blob: 1bad6f4e9bfaabe289aa6630937a1df7f98729f2 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Performance analysis tools for Linux"
2DESCRIPTION = "Performance counters for Linux are a new kernel-based \
3subsystem that provide a framework for all things \
4performance analysis. It covers hardware level \
5(CPU/PMU, Performance Monitoring Unit) features \
6and software features (software counters, tracepoints) \
7as well."
Joel Stanleye252c312017-12-14 15:11:12 +10308HOMEPAGE = "https://perf.wiki.kernel.org/index.php/Main_Page"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10LICENSE = "GPLv2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12PR = "r9"
13
Joel Stanleye252c312017-12-14 15:11:12 +103014PACKAGECONFIG ??= "scripting tui libunwind"
15PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016# gui support was added with kernel 3.6.35
17# since 3.10 libnewt was replaced by slang
18# to cover a wide range of kernel we add both dependencies
Joel Stanleye252c312017-12-14 15:11:12 +103019PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
20PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
21PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
22PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
23PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024
25DEPENDS = " \
26 virtual/${MLPREFIX}libc \
27 ${MLPREFIX}elfutils \
28 ${MLPREFIX}binutils \
Joel Stanleye252c312017-12-14 15:11:12 +103029 bison-native flex-native xz \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060030 xmlto-native \
31 asciidoc-native \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032"
33
34do_configure[depends] += "virtual/kernel:do_shared_workdir"
35
36PROVIDES = "virtual/perf"
37
Joel Stanleye252c312017-12-14 15:11:12 +103038inherit linux-kernel-base kernel-arch
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039
40# needed for building the tools/perf Python bindings
Joel Stanleye252c312017-12-14 15:11:12 +103041inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'pythonnative', '', d)}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042inherit python-dir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043export PYTHON_SITEPACKAGES_DIR
44
45#kernel 3.1+ supports WERROR to disable warnings as errors
46export WERROR = "0"
47
48do_populate_lic[depends] += "virtual/kernel:do_patch"
49
50# needed for building the tools/perf Perl binding
Joel Stanleye252c312017-12-14 15:11:12 +103051inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perlnative', '', d)}
52inherit cpan-base
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053# Env var which tells perl if it should use host (no) or target (yes) settings
54export PERLCONFIGTARGET = "${@is_target(d)}"
55export PERL_INC = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}/CORE"
56export PERL_LIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}"
57export PERL_ARCHLIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/${@get_perl_version(d)}"
58
59inherit kernelsrc
60
61B = "${WORKDIR}/${BPN}-${PV}"
62SPDX_S = "${S}/tools/perf"
63
Patrick Williamsc124f4f2015-09-15 14:41:29 -050064# The LDFLAGS is required or some old kernels fails due missing
65# symbols and this is preferred than requiring patches to every old
66# supported kernel.
67LDFLAGS="-ldl -lutil"
68
69EXTRA_OEMAKE = '\
70 -C ${S}/tools/perf \
71 O=${B} \
72 CROSS_COMPILE=${TARGET_PREFIX} \
73 ARCH=${ARCH} \
74 CC="${CC}" \
75 AR="${AR}" \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060076 LD="${LD}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050077 EXTRA_CFLAGS="-ldw" \
Joel Stanleye252c312017-12-14 15:11:12 +103078 EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050079 perfexecdir=${libexecdir} \
Joel Stanleye252c312017-12-14 15:11:12 +103080 NO_GTK2=1 NO_DWARF=1 \
81 ${PACKAGECONFIG_CONFARGS} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050082'
83
84EXTRA_OEMAKE += "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050085 'DESTDIR=${D}' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050086 'prefix=${prefix}' \
87 'bindir=${bindir}' \
88 'sharedir=${datadir}' \
89 'sysconfdir=${sysconfdir}' \
90 'perfexecdir=${libexecdir}/perf-core' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050091 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
92 'sharedir=${@os.path.relpath(datadir, prefix)}' \
93 'mandir=${@os.path.relpath(mandir, prefix)}' \
94 'infodir=${@os.path.relpath(infodir, prefix)}' \
95"
96
Joel Stanleye252c312017-12-14 15:11:12 +103097PERF_EXTRA_LDFLAGS = ""
98
99# MIPS N32
100PERF_EXTRA_LDFLAGS_mipsarchn32eb = "-m elf32btsmipn32"
101PERF_EXTRA_LDFLAGS_mipsarchn32el = "-m elf32ltsmipn32"
102
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500103do_compile() {
104 # Linux kernel build system is expected to do the right thing
105 unset CFLAGS
106 oe_runmake all
107}
108
109do_install() {
110 # Linux kernel build system is expected to do the right thing
111 unset CFLAGS
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500112 oe_runmake install
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500113 # we are checking for this make target to be compatible with older perf versions
Joel Stanleye252c312017-12-14 15:11:12 +1030114 if ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'true', 'false', d)} && grep -q install-python_ext ${S}/tools/perf/Makefile*; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500115 oe_runmake DESTDIR=${D} install-python_ext
116 fi
117}
118
119do_configure_prepend () {
120 # Fix for rebuilding
121 rm -rf ${B}/
Patrick Williamsd7e96312015-09-22 08:09:05 -0500122 mkdir -p ${B}/
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500123
124 # If building a multlib based perf, the incorrect library path will be
125 # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit
126 # build, with a 64 bit multilib, the arch won't match and the detection of a
127 # 64 bit build (and library) are not exected. To ensure that libraries are
128 # installed to the correct location, we can use the weak assignment in the
129 # config/Makefile.
130 #
131 # Also need to relocate .config-detected to $(OUTPUT)/config-detected
132 # for kernel sources that do not already do this
133 # as two builds (e.g. perf and lib32-perf from mutlilib can conflict
134 # with each other if its in the shared source directory
135 #
136 if [ -e "${S}/tools/perf/config/Makefile" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600137 perfconfig="${S}/tools/perf/config/Makefile"
138 fi
139 if [ -e "${S}/tools/perf/Makefile.config" ]; then
140 perfconfig="${S}/tools/perf/Makefile.config"
141 fi
142 if [ -n "${perfconfig}" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500143 # Match $(prefix)/$(lib) and $(prefix)/lib
144 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
145 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
146 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600147 ${perfconfig}
148 fi
149 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
150 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
151 # will use the relative path 'share/man', in the way it will resulting in
152 # incorrect installation for man pages.
153 if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then
154 sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500155 fi
156 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
157 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
158 ${S}/tools/perf/Makefile.perf
159 sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
160 ${S}/tools/perf/Makefile.perf
161 fi
162 sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
Patrick Williamsd7e96312015-09-22 08:09:05 -0500163 ${S}/tools/perf/Makefile*
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500164
165 if [ -e "${S}/tools/build/Makefile.build" ]; then
166 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
167 ${S}/tools/build/Makefile.build
168 fi
169
170 # We need to ensure the --sysroot option in CC is preserved
171 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
172 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf
173 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600174 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500175 fi
176 if [ -e "${S}/tools/lib/api/Makefile" ]; then
177 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
178 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600179 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/lib/api/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500180 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500181 if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
182 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
183 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
184 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500185 if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
186 sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
187 fi
188 if [ -e "${S}/tools/build/Makefile.feature" ]; then
189 sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature
190 fi
191
192 # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include
193 if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then
194 sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c
195 fi
196 if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then
197 sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c
198 sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c
199 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500200
201 # use /usr/bin/env instead of version specific python
202 for s in `find ${S}/tools/perf/scripts/python/ -name '*.py'`; do
203 sed -i 's,/usr/bin/python2,/usr/bin/env python,' "${s}"
204 done
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500205}
206
207python do_package_prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500208 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500209}
210
211PACKAGE_ARCH = "${MACHINE_ARCH}"
212
213
214PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
215
216RDEPENDS_${PN} += "elfutils bash"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600217RDEPENDS_${PN}-doc += "man"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500218RDEPENDS_${PN}-archive =+ "bash"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500219RDEPENDS_${PN}-python =+ "bash python python-modules"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500220RDEPENDS_${PN}-perl =+ "bash perl perl-modules"
221RDEPENDS_${PN}-tests =+ "python"
222
Joel Stanleye252c312017-12-14 15:11:12 +1030223RSUGGESTS_SCRIPTING = "${@bb.utils.contains('PACKAGECONFIG', 'scripting', '${PN}-perl ${PN}-python', '',d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500224RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"
225
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600226#FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core /usr/lib64/traceevent ${libdir}/traceevent"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500227FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500228FILES_${PN}-archive = "${libdir}/perf/perf-core/perf-archive"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500229FILES_${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600230FILES_${PN}-python = "${libdir}/perf/perf-core/scripts/python ${PYTHON_SITEPACKAGES_DIR}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500231FILES_${PN}-python += "${libexecdir}/perf-core/scripts/python/*"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500232FILES_${PN}-perl = "${libdir}/perf/perf-core/scripts/perl"
233
234
235INHIBIT_PACKAGE_DEBUG_SPLIT="1"