blob: 866e8526eccc9f539651bf6f581e587d05568e91 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05004
Brad Bishop37a0e4d2017-12-04 01:01:44 -05005CVE_PRODUCT = "libtiff"
6
Patrick Williamsc0f7c042017-02-23 20:41:17 -06007SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05008 file://libtool2.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009 file://libtiff-CVE-2017-5225.patch \
10 file://CVE-2017-9147.patch \
11 file://CVE-2017-9936.patch \
12 file://CVE-2017-10688.patch \
13 file://CVE-2017-11335.patch \
14 file://CVE-2016-10271.patch \
15 file://CVE-2016-10093.patch \
16 file://CVE-2016-10268.patch \
17 file://CVE-2016-10266.patch \
18 file://CVE-2016-10267.patch \
19 file://CVE-2016-10269.patch \
20 file://CVE-2016-10270.patch \
21 file://CVE-2017-7592.patch \
22 file://CVE-2017-7594-p1.patch \
23 file://CVE-2017-7594-p2.patch \
24 file://CVE-2017-7595.patch \
25 file://CVE-2017-7596.patch \
26 file://CVE-2017-7598.patch \
27 file://CVE-2017-7601.patch \
28 file://CVE-2017-7602.patch \
29 file://CVE-2017-7593.patch \
30 "
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050031
Brad Bishop37a0e4d2017-12-04 01:01:44 -050032SRC_URI[md5sum] = "77ae928d2c6b7fb46a21c3a29325157b"
33SRC_URI[sha256sum] = "9f43a2cfb9589e5cecaa66e16bf87f814c945f22df7ba600d63aac4632c4f019"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050034
35# exclude betas
36UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
37
38inherit autotools
39
40CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
41
42PACKAGECONFIG ?= "cxx jpeg zlib lzma \
43 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
44
45PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
46PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
47PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
48PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
49
50# Convert single-strip uncompressed images to multiple strips of specified
51# size (default: 8192) to reduce memory usage
52PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
53
54# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
55PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
56
57# Control picking up YCbCr subsample info. Disable to support files lacking
58# the tag
59PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
60
61# Support a mechanism allowing reading large strips (usually one strip files)
62# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
63PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
64
65PACKAGES =+ "tiffxx tiff-utils"
66FILES_tiffxx = "${libdir}/libtiffxx.so.*"
67FILES_tiff-utils = "${bindir}/*"
68
69BBCLASSEXTEND = "native"