blob: 0ceed960e250f81afb2a93604f88a17dd34a38be [file] [log] [blame]
Brad Bishop93fb5352015-09-09 03:59:20 +00001# Common code for dbus applications using c.
2
3inherit obmc-phosphor-systemd
4inherit obmc-phosphor-license
5
6DEPENDS += "glib-2.0"
Brad Bishop09494ec2015-10-18 22:21:04 -04007
8INSTALL_NAME ?= "${PN}"
9BIN_NAME ?= "${INSTALL_NAME}"
Brad Bishop93fb5352015-09-09 03:59:20 +000010
11do_install_append() {
12 # install the binary
13 install -d ${D}${sbindir}
Brad Bishop09494ec2015-10-18 22:21:04 -040014 install -m 0755 ${S}/${BIN_NAME} ${D}${sbindir}/${INSTALL_NAME}
Brad Bishop93fb5352015-09-09 03:59:20 +000015}