blob: 25833f507ba18948a69fbb499c50ef2062eba46f [file] [log] [blame]
Tom Joseph7b827742017-01-16 16:43:05 +05301SUMMARY = "Phosphor Network IPMI Daemon"
2DESCRIPTION = "Daemon to support IPMI protocol over network"
3HOMEPAGE = "https://github.com/openbmc/phosphor-net-ipmid"
4PR = "r1"
Patrick Ventureafba95a2018-10-01 20:54:34 -07005PV = "1.0+git${SRCPV}"
Brad Bishop75f03872018-11-03 09:41:57 -07006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Tom Joseph7b827742017-01-16 16:43:05 +05308
9inherit autotools pkgconfig
Tom Joseph7b827742017-01-16 16:43:05 +053010inherit obmc-phosphor-systemd
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-mapper"
14DEPENDS += "systemd"
15DEPENDS += "phosphor-ipmi-host"
Tom Joseph26b20722018-09-21 00:56:43 -050016RDEPENDS_${PN} += "iptables"
Tom Joseph7b827742017-01-16 16:43:05 +053017
18SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
Tom Joseph08589c22018-10-17 07:44:52 -050019SRC_URI += "file://ipmi-net-firewall.sh"
Andrew Geissler6f14d742019-04-02 08:32:35 +000020SRCREV = "8af90ebcc552e243ae85aa9e9da1a00fbecab56c"
Tom Joseph7b827742017-01-16 16:43:05 +053021
22S = "${WORKDIR}/git"
23
Tom Joseph08589c22018-10-17 07:44:52 -050024do_install_append() {
Andrew Geissler303d7f42019-04-01 17:12:58 +000025 install -d ${D}${sbindir}
Tom Joseph08589c22018-10-17 07:44:52 -050026 install -m 0755 ${WORKDIR}/ipmi-net-firewall.sh \
27 ${D}${sbindir}/ipmi-net-firewall.sh
28}
29
Tom Joseph62b03f22017-01-27 14:11:58 +053030SYSTEMD_SERVICE_${PN} = " \
31 ${PN}.service \
32 ${PN}.socket \
33 "