blob: 0158f8bc74666d73e600cc49212c92b9d66466b4 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "https://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPL-3.0-or-later"
5
Patrick Williamsac13d5f2023-11-24 18:59:46 -06006DEPENDS += "libtalloc libtirpc cmocka"
Andrew Geissler517393d2023-01-13 08:55:19 -06007RDEPENDS:python3-tevent = "python3"
8
9export PYTHONHASHSEED="1"
10
11SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
12 file://0001-Add-configure-options-for-packages.patch \
13 file://0002-Fix-pyext_PATTERN-for-cross-compilation.patch \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060014 file://run-ptest \
Andrew Geissler517393d2023-01-13 08:55:19 -060015 "
16
Andrew Geissler517393d2023-01-13 08:55:19 -060017LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=47386b7c539bf2706b7ce52dc9341681"
18
Patrick Williams705982a2024-01-12 09:51:57 -060019SRC_URI[sha256sum] = "1aa58f21017ed8c2f606ae84aa7e795b5439edd4dd5f68f1a388a7d6fb40f682"
Andrew Geissler517393d2023-01-13 08:55:19 -060020
Andrew Geisslerc5535c92023-01-27 16:10:19 -060021inherit pkgconfig ptest waf-samba
Andrew Geissler517393d2023-01-13 08:55:19 -060022
23PACKAGECONFIG ??= "\
24 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
26"
27PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
28PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
Andrew Geissler517393d2023-01-13 08:55:19 -060029PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
30PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
31PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
32
33SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
34
35S = "${WORKDIR}/tevent-${PV}"
36
Patrick Williams705982a2024-01-12 09:51:57 -060037# Cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
38# to cross Popen
Andrew Geissler517393d2023-01-13 08:55:19 -060039export WAF_NO_PREFORK="yes"
40
41EXTRA_OECONF += "--disable-rpath \
42 --disable-rpath-install \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060043 --bundled-libraries=NONE \
Andrew Geissler517393d2023-01-13 08:55:19 -060044 --builtin-libraries=replace \
45 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
46 --without-gettext \
47 "
48
Patrick Williamsac13d5f2023-11-24 18:59:46 -060049do_install_ptest() {
50 install -d ${D}${PTEST_PATH}/tests
51 install -m 0755 ${B}/bin/test_tevent_* ${D}${PTEST_PATH}/tests/
52 install -m 0755 ${B}/bin/replace_testsuite ${D}${PTEST_PATH}/tests/
Andrew Geisslerc5535c92023-01-27 16:10:19 -060053}
54
Andrew Geissler517393d2023-01-13 08:55:19 -060055PACKAGES += "python3-tevent"
56
57RPROVIDES:${PN}-dbg += "python3-tevent-dbg"
58
Andrew Geissler517393d2023-01-13 08:55:19 -060059FILES:python3-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
60
61INSANE_SKIP:${MLPREFIX}python3-tevent = "dev-so"