blob: 1a48a88c29d93be42325b0f041654e53e47d8ef6 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Arpeggio is a recursive descent parser with memoization based on PEG grammars (aka Packrat parser)"
2HOMEPAGE = "https://pypi.org/project/Arpeggio/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=33b8d1ba459a2fa4d801acfd1d1b7ceb"
5
Andrew Geissler8f840682023-07-21 09:09:43 -05006SRC_URI[sha256sum] = "c790b2b06e226d2dd468e4fbfb5b7f506cec66416031fde1441cf1de2a0ba700"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007
8PYPI_PACKAGE = "Arpeggio"
9inherit pypi setuptools3
10
11# setup.py of Arpeggio needs this.
12DEPENDS += "\
13 ${PYTHON_PN}-pytest-runner-native \
14 ${PYTHON_PN}-wheel-native \
15"
16
17BBCLASSEXTEND = "native nativesdk"