blob: f0ca630ccda557da131a7e63f934f5c3a9f16904 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Simplified object serialization in python"
2DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes."
Andrew Geissler517393d2023-01-13 08:55:19 -06003HOMEPAGE = "https://github.com/marshmallow-code/marshmallow"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "\
6 file://LICENSE;md5=5bccd400dedfa74364481e56aacc0b4a \
7 file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb"
8
9SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev"
10
Patrick Williams2a254922023-08-11 09:48:11 -050011SRCREV = "dda9a8014dfe1bcb35e21307cfd5a8e19615a284"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17PIP_INSTALL_PACKAGE = "marshmallow"
18
19RDEPENDS:${PN} += " \
20 python3-core \
21 python3-datetime \
22 python3-netclient \
23 python3-numbers \
24 python3-json \
25 python3-pprint \
26 python3-packaging \
27"