blob: 72c369100adaef1004bf50f0a7399ce6c987061b [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "matplotlib: plotting with Python"
2DESCRIPTION = "\
3Matplotlib is a Python 2D plotting library which produces \
4publication-quality figures in a variety of hardcopy formats \
5and interactive environments across platforms."
6HOMEPAGE = "https://github.com/matplotlib/matplotlib"
7SECTION = "devel/python"
8LICENSE = "PSF-2.0"
9LIC_FILES_CHKSUM = "\
Patrick Williams2a254922023-08-11 09:48:11 -050010 file://setup.py;beginline=293;endline=293;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \
Patrick Williams92b42cb2022-09-03 06:53:57 -050011 file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
12"
13
14DEPENDS = "\
15 freetype \
16 libpng \
17 python3-numpy-native \
18 python3-pip-native \
19 python3-dateutil-native \
20 python3-pytz-native \
21 python3-certifi-native \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050022 python3-setuptools-scm-native \
Patrick Williams2a254922023-08-11 09:48:11 -050023 python3-pybind11-native \
Patrick Williams92b42cb2022-09-03 06:53:57 -050024"
Patrick Williams2a254922023-08-11 09:48:11 -050025SRC_URI[sha256sum] = "a8cdb91dddb04436bd2f098b8fdf4b81352e68cf4d2c6756fcc414791076569b"
Patrick Williams92b42cb2022-09-03 06:53:57 -050026
27inherit pypi setuptools3 pkgconfig
28
29# Stop the component from attempting to download when it detects a missing
30# dependency
Andrew Geisslerc5535c92023-01-27 16:10:19 -060031SRC_URI += "file://matplotlib-disable-download.patch \
Patrick Williams2a254922023-08-11 09:48:11 -050032"
Patrick Williams92b42cb2022-09-03 06:53:57 -050033
34# This python module requires a full copy of freetype-2.6.1
35SRC_URI += "https://downloads.sourceforge.net/project/freetype/freetype2/2.6.1/freetype-2.6.1.tar.gz;name=freetype;subdir=matplotlib-${PV}/build"
36SRC_URI[freetype.sha256sum] = "0a3c7dfbda6da1e8fce29232e8e96d987ababbbf71ebc8c75659e4132c367014"
37
38# This python module requires a full copy of 'qhull-2020'
39SRC_URI += "http://www.qhull.org/download/qhull-2020-src-8.0.2.tgz;name=qhull;subdir=matplotlib-${PV}/build"
40SRC_URI[qhull.sha256sum] = "b5c2d7eb833278881b952c8a52d20179eab87766b00b865000469a45c1838b7e"
41
42# LTO with clang needs lld
43LDFLAGS:append:toolchain-clang = " -fuse-ld=lld"
44LDFLAGS:remove:toolchain-clang:mips = "-fuse-ld=lld"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060045LDFLAGS:remove:toolchain-clang:riscv64 = "-fuse-ld=lld"
46LDFLAGS:remove:toolchain-clang:riscv32 = "-fuse-ld=lld"
Patrick Williams92b42cb2022-09-03 06:53:57 -050047RDEPENDS:${PN} = "\
48 freetype \
49 libpng \
50 python3-numpy \
51 python3-pyparsing \
52 python3-cycler \
53 python3-dateutil \
54 python3-kiwisolver \
55 python3-pytz \
56 python3-pillow \
57 python3-packaging \
58"
59
60ENABLELTO:toolchain-clang:riscv64 = "echo enable_lto = False >> ${S}/mplsetup.cfg"
61ENABLELTO:toolchain-clang:riscv32 = "echo enable_lto = False >> ${S}/mplsetup.cfg"
62ENABLELTO:toolchain-clang:mips = "echo enable_lto = False >> ${S}/mplsetup.cfg"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050063
Patrick Williams92b42cb2022-09-03 06:53:57 -050064do_compile:prepend() {
65 echo [libs] > ${S}/mplsetup.cfg
66 echo system_freetype = True >> ${S}/mplsetup.cfg
67 ${ENABLELTO}
68}
69
70BBCLASSEXTEND = "native"