Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 1 | SUMMARY = "PKCS#11 (Cryptoki) support for Python" |
| 2 | DESCRIPTION = "A high level, “more Pythonic” interface to the PKCS#11 (Cryptoki) standard to support HSM and Smartcard devices in Python." |
| 3 | HOMEPAGE = "https://pypi.org/project/python-pkcs11/" |
| 4 | SECTION = "devel/python" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://README.rst;beginline=337;endline=358;md5=f68bda54505b4002e6ec86e08125ef79" |
| 7 | |
| 8 | SRC_URI[sha256sum] = "9737e0c24cabb8bc9d48bf8c57c3df2a70f8cdd96b70c50290803286f9e46bf7" |
| 9 | |
| 10 | PYPI_PACKAGE = "python-pkcs11" |
| 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | BBCLASSEXTEND = "native" |
| 15 | |
| 16 | DEPENDS += " \ |
| 17 | python3-cython-native \ |
| 18 | python3-setuptools-scm-native \ |
| 19 | python3 \ |
| 20 | " |
| 21 | |
| 22 | RDEPENDS:${PN} += " \ |
| 23 | python3-asn1crypto \ |
| 24 | python3-cached-property \ |
| 25 | " |