blob: 8e1cd349a0ef6f7f3e28092bc7de5fe9d17774e4 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Asynchronous I/O library"
2DESCRIPTION = "Asynchronous input/output library that uses the kernels native interface"
3HOMEPAGE = "http://lse.sourceforge.net/io/aio.html"
4
5LICENSE = "LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499"
7
8SRC_URI = "git://pagure.io/libaio.git;protocol=https \
9 file://00_arches.patch \
Andrew Geissler706d5aa2021-02-12 15:55:30 -060010 file://destdir.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011 file://libaio_fix_for_mips_syscalls.patch \
12 file://system-linkage.patch \
13 "
Andrew Geissler706d5aa2021-02-12 15:55:30 -060014SRCREV = "f66be22ab0a59a39858900ab72a8c6a6e8b0b7ec"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE =+ "prefix=${prefix} includedir=${includedir} libdir=${libdir}"
18
19do_install () {
20 oe_runmake install DESTDIR=${D}
21}
22
Andrew Geissler99467da2019-02-25 18:54:23 -060023BBCLASSEXTEND = "native nativesdk"