blob: 2478ba07d80ac4c7495b1fdef3aad15bc4d61f9f [file] [log] [blame]
Andrew Geissler4ed12e12020-06-05 18:00:41 -05001SUMMARY = "Library for reading extended image information (EXIF) from JPEG files"
2HOMEPAGE = "https://libexif.github.io/"
3SECTION = "libs"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad"
6
7def version_underscore(v):
8 return "_".join(v.split("."))
9
10SRC_URI = "https://github.com/libexif/libexif/releases/download/libexif-${@version_underscore("${PV}")}-release/libexif-${PV}.tar.xz \
11 "
12
13SRC_URI[sha256sum] = "5048f1c8fc509cc636c2f97f4b40c293338b6041a5652082d5ee2cf54b530c56"
14
15UPSTREAM_CHECK_URI = "https://github.com/libexif/libexif/releases/"
16
17inherit autotools gettext
18
19EXTRA_OECONF += "--disable-docs"
Andrew Geissler635e0e42020-08-21 15:58:33 -050020
21BBCLASSEXTEND = "native nativesdk"