blob: 35c019c1001ac69cbe1e96677c09c994c6fb0eb3 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "There are two major versions of the PCRE library. The \
2newest version is PCRE2, which is a re-working of the original PCRE \
3library to provide an entirely new API. The original, very widely \
4deployed PCRE library's API and feature are stable, future releases \
5 will be for bugfixes only. All new future features will be to PCRE2, \
6not the original PCRE 8.x series."
7SUMMARY = "Perl Compatible Regular Expressions version 2"
8HOMEPAGE = "http://www.pcre.org"
9SECTION = "devel"
10LICENSE = "BSD-3-Clause"
Andrew Geissler706d5aa2021-02-12 15:55:30 -060011LIC_FILES_CHKSUM = "file://LICENCE;md5=a06590e9bd4c229532364727aaeaf084"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
Andrew Geissler4ed12e12020-06-05 18:00:41 -050013SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre2-${PV}.tar.bz2"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
Andrew Geissler706d5aa2021-02-12 15:55:30 -060015SRC_URI[sha256sum] = "9ccba8e02b0ce78046cdfb52e5c177f0f445e421059e43becca4359c669d4613"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17CVE_PRODUCT = "pcre2"
18
19S = "${WORKDIR}/pcre2-${PV}"
20
21PROVIDES += "pcre2"
22DEPENDS += "bzip2 zlib"
23
24BINCONFIG = "${bindir}/pcre2-config"
25
26inherit autotools binconfig-disabled
27
28EXTRA_OECONF = "\
29 --enable-newline-is-lf \
Andrew Geissler82c905d2020-04-13 13:39:40 -050030 --with-link-size=2 \
31 --with-match-limit=10000000 \
32 --enable-pcre2-16 \
33 --enable-pcre2-32 \
34"
Andrew Geissler82c905d2020-04-13 13:39:40 -050035CFLAGS += "-D_REENTRANT"
36CXXFLAGS_append_powerpc = " -lstdc++"
37
Andrew Geissler82c905d2020-04-13 13:39:40 -050038PACKAGES =+ "libpcre2-16 libpcre2-32 pcre2grep pcre2grep-doc pcre2test pcre2test-doc"
39
40SUMMARY_pcre2grep = "grep utility that uses perl 5 compatible regexes"
41SUMMARY_pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs"
42SUMMARY_pcre2test = "program for testing Perl-comatible regular expressions"
43SUMMARY_pcre2test-doc = "program for testing Perl-comatible regular expressions - docs"
44
45FILES_libpcre2-16 = "${libdir}/libpcre2-16.so.*"
46FILES_libpcre2-32 = "${libdir}/libpcre2-32.so.*"
47FILES_pcre2grep = "${bindir}/pcre2grep"
48FILES_pcre2grep-doc = "${mandir}/man1/pcre2grep.1"
49FILES_pcre2test = "${bindir}/pcre2test"
50FILES_pcre2test-doc = "${mandir}/man1/pcre2test.1"
51
52BBCLASSEXTEND = "native nativesdk"