blob: 3ee93ffe58067d072601db62f1b0a27bf7eb4248 [file] [log] [blame]
Charles Kearney7237a3e2023-04-07 21:15:03 +00001# TODO: Manually copy the U-Boot signing key and customer-key-block here:
2HPE_GXP_KEY_FILES_DIR = "${COREBASE}/meta-hpe/meta-gxp/recipes-bsp/image/files"
3
4inherit deploy
5
6do_deploy () {
7 install -d ${DEPLOYDIR}
8
9 # Copy in the bootblock
10 install -m 644 ${HPE_GXP_KEY_FILES_DIR}/gxp2-bootblock.bin ${DEPLOYDIR}/gxp-bootblock.bin
11
12 # Copy in files from the files subdirectory
13 install -m 644 ${HPE_GXP_KEY_FILES_DIR}/header.sig ${DEPLOYDIR}/hpe-uboot-header.section
14 install -m 644 ${HPE_GXP_KEY_FILES_DIR}/header-512.sig ${DEPLOYDIR}/hpe-uboot-header-512.section
15
16 # Copy in the U-Boot signing key
17 install -m 644 ${HPE_GXP_KEY_FILES_DIR}/customer_private_key.pem ${DEPLOYDIR}/hpe-uboot-signing-key.pem
18
19 # Copy in the customer keyblock
20 install -m 644 ${HPE_GXP_KEY_FILES_DIR}/customer-key-block ${DEPLOYDIR}/customer-key-block
21}