blob: b960affac4ca8b3a9a29c7715a18185fb697d5cc [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
2HOMEPAGE = "https://github.com/aio-libs/multidict/"
Andrew Geissler2ee498a2020-05-29 15:52:06 -05003
Brad Bishop26bdd442019-08-16 17:08:17 -04004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a"
6
Andrew Geissler72956ed2021-01-08 16:11:14 -06007SRC_URI[sha256sum] = "25b4e5f22d3a37ddf3effc0710ba692cfc792c2b9edfb9c05aefe823256e84d5"
Brad Bishop26bdd442019-08-16 17:08:17 -04008
Andrew Geissler2ee498a2020-05-29 15:52:06 -05009inherit pypi setuptools3 ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
Andrew Geissler2ee498a2020-05-29 15:52:06 -050023
24BBCLASSEXTEND = "native nativesdk"