Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 7 | inherit python_pyo3 python_setuptools_build_meta |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 8 | |
| 9 | DEPENDS += "python3-setuptools-rust-native" |
| 10 | |
| 11 | python_setuptools3_rust_do_configure() { |
| 12 | python_pyo3_do_configure |
| 13 | cargo_common_do_configure |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 14 | python_pep517_do_configure |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 15 | } |
| 16 | |
| 17 | EXPORT_FUNCTIONS do_configure |