blob: 9585dfc2c61cf1860df7fda42583a0e9a402dacb [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Error - Error/exception handling in an OO-ish way"
2DESCRIPTION = "The Error package provides two interfaces. Firstly \
3Error provides a procedural interface to exception handling. \
4Secondly Error is a base class for errors/exceptions that can \
5either be thrown, for subsequent catch, or can simply be recorded."
6HOMEPAGE = "https://github.com/shlomif/perl-error.pm"
7SECTION = "libs"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
11
Andrew Geisslerd5838332022-05-27 11:33:10 -050012PR = "r1"
Andrew Geisslerd5838332022-05-27 11:33:10 -050013
Andrew Geissler82c905d2020-04-13 13:39:40 -050014DEPENDS += "perl"
15
Patrick Williams213cb262021-08-07 19:21:33 -050016RDEPENDS:${PN} += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050017 perl-module-carp \
18 perl-module-exporter \
19 perl-module-scalar-util \
20 perl-module-overload \
21 perl-module-strict \
22 perl-module-vars \
23 perl-module-warnings \
24"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027 perl-module-base \
28 perl-module-file-spec \
29 perl-module-io-handle \
30 perl-module-ipc-open3 \
31 perl-module-lib \
32 perl-module-test-more \
33"
34
35SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
36
37SRC_URI[md5sum] = "6732b1c6207e4a9a3e2987c88368039a"
38SRC_URI[sha256sum] = "1a23f7913032aed6d4b68321373a3899ca66590f4727391a091ec19c95bf7adc"
39
40S = "${WORKDIR}/Error-${PV}"
41
42inherit cpan ptest-perl
43
Patrick Williams213cb262021-08-07 19:21:33 -050044do_install:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050045 # test requires "-T" (taint) command line option
46 rm -rf ${B}/t/pod-coverage.t
47}
48
49BBCLASSEXTEND = "native"