blob: 247f64c106699301961eda1293b83770f1a6cfb5 [file] [log] [blame]
Brad Bishopa7127322015-10-06 00:27:43 -04001DESCRIPTION = "Linux kernel for OpenBMC"
2SECTION = "kernel"
3LICENSE = "GPLv2"
4
5KBRANCH ?= "dev"
Brad Bishopfebd61a2015-10-30 03:11:05 -04006KCONFIG_MODE="--alldefconfig"
Brad Bishopa7127322015-10-06 00:27:43 -04007
8SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
Brad Bishopa7127322015-10-06 00:27:43 -04009
10LINUX_VERSION ?= "4.2"
Brad Bishopfebd61a2015-10-30 03:11:05 -040011LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
Brad Bishopa7127322015-10-06 00:27:43 -040012
Brad Bishopc72d7062015-10-28 10:21:32 -040013SRCREV="openbmc-20151028-1"
Brad Bishopa7127322015-10-06 00:27:43 -040014
15PV = "${LINUX_VERSION}+git${SRCPV}"
16
17COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
18
19inherit kernel
20require recipes-kernel/linux/linux-yocto.inc
Brad Bishop739d7a22015-11-01 20:13:47 -050021
22do_patch_append() {
23 for DTB in "${KERNEL_DEVICETREE}"; do
24 DT=`basename ${DTB} .dtb`
25 if [ -r "${WORKDIR}/${DT}.dts" ]; then
26 cp ${WORKDIR}/${DT}.dts \
27 ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts
28 fi
29 done
30}