blob: 4abec0a01c8bc85288dc3cbb4dc435b1d9af71ec [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Run a subprocess in a pseudo terminal"
2HOMEPAGE = "http://ptyprocess.readthedocs.io/en/latest/"
3SECTION = "devel/python"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=cfdcd51fa7d5808da4e74346ee394490"
6
7SRCNAME = "ptyprocess"
8
Andrew Geisslereef63862021-01-29 15:58:13 -06009SRC_URI[sha256sum] = "5c5d0a3b48ceee0b48485e0c26037c0acd7d29765ca3fbb5cb3831d347423220"
Andrew Geisslerc87764f2020-06-27 00:16:32 -050010
Andrew Geissler9aee5002022-03-30 16:27:02 +000011inherit pypi python_flit_core
Andrew Geisslerc87764f2020-06-27 00:16:32 -050012
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN} = "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060018 python3-core \
19 python3-fcntl \
20 python3-terminal \
21 python3-resource \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050022"
23
24BBCLASSEXTEND = "native nativesdk"
25
26inherit ptest
27
28SRC_URI += " \
29 file://run-ptest \
30"
31
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060033 bash \
34 python3-fcntl \
35 python3-pytest \
36 python3-resource \
37 python3-terminal \
38 python3-unittest-automake-output \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050039"
40
41do_install_ptest() {
42 install -d ${D}${PTEST_PATH}/tests
43 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
44}