blob: 1986263117b204990cab3a208d89dc98ae144b76 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
Andrew Geissler748a4832020-07-24 16:24:21 -05004LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005
6inherit pypi setuptools3 ptest
7
Andrew Geissler748a4832020-07-24 16:24:21 -05008SRC_URI[md5sum] = "0349106ac02f2bfe565dd6d5594e3a15"
9SRC_URI[sha256sum] = "c35965d010ce31b23eeb663ed3cc8c906275d6be1a34393a1d73a41febf4a048"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
11RDEPENDS_${PN}_class-target += "\
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-doctest \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-pickle \
16 ${PYTHON_PN}-pprint \
17 ${PYTHON_PN}-threading \
18"
19
20BBCLASSEXTEND = "native nativesdk"
21
22SRC_URI += " \
23 file://run-ptest \
24"
25
26RDEPENDS_${PN}-ptest += " \
27 ${PYTHON_PN}-pytest \
28"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/pytz
32 install -d ${D}${PTEST_PATH}/pytz/tests
33 cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
Andrew Geissler748a4832020-07-24 16:24:21 -050034 cp -f ${S}/README.rst ${D}${PTEST_PATH}/
Andrew Geissler82c905d2020-04-13 13:39:40 -050035
36}