blob: dd352e48481f3f5479ec1d7e478d62399b82baac [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001# SPDX-License-Identifier: MIT
2# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "Automate and standardize testing in Python. It is part of a larger vision of easing the packaging, testing and release process of Python software (alongside pytest and devpi)."
5HOMEPAGE = "http://tox.readthedocs.org/"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=11610a9d8fd95649cf8159be12b98cb7"
8
Patrick Williams39653562024-03-01 08:54:02 -06009SRC_URI[sha256sum] = "dd789a554c16c4b532924ba393c92fc8991323c4b3d466712bfecc8c9b9f24f7"
Andrew Geissler8f840682023-07-21 09:09:43 -050010
11BBCLASSEXTEND = "native nativesdk"
12inherit pypi python_hatchling
13
14DEPENDS += "\
Patrick Williams39653562024-03-01 08:54:02 -060015 python3-hatch-vcs-native \
Andrew Geissler8f840682023-07-21 09:09:43 -050016"
17
18RDEPENDS:${PN} += "\
Patrick Williams39653562024-03-01 08:54:02 -060019 python3-cachetools \
20 python3-chardet \
21 python3-colorama \
22 python3-filelock \
23 python3-packaging \
24 python3-platformdirs \
25 python3-pluggy \
26 python3-pyproject-api \
27 python3-tomli \
28 python3-virtualenv \
Andrew Geissler8f840682023-07-21 09:09:43 -050029"
30
31# Install all built-in python3 modules, as the software tested with tox might
32# depend on it. Tox will attempt to install all required dependencies
33# in a virtualenv using pip, but this obviously does not include the built-in modules.
Patrick Williams39653562024-03-01 08:54:02 -060034RDEPENDS:${PN} += "python3-modules"