Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 1 | # SPDX-License-Identifier: MIT |
| 2 | # Copyright (C) 2023 iris-GmbH infrared & intelligent sensors |
| 3 | |
| 4 | SUMMARY = "Automate and standardize testing in Python. It is part of a larger vision of easing the packaging, testing and release process of Python software (alongside pytest and devpi)." |
| 5 | HOMEPAGE = "http://tox.readthedocs.org/" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=11610a9d8fd95649cf8159be12b98cb7" |
| 8 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "dd789a554c16c4b532924ba393c92fc8991323c4b3d466712bfecc8c9b9f24f7" |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 10 | |
| 11 | BBCLASSEXTEND = "native nativesdk" |
| 12 | inherit pypi python_hatchling |
| 13 | |
| 14 | DEPENDS += "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 15 | python3-hatch-vcs-native \ |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN} += "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 19 | python3-cachetools \ |
| 20 | python3-chardet \ |
| 21 | python3-colorama \ |
| 22 | python3-filelock \ |
| 23 | python3-packaging \ |
| 24 | python3-platformdirs \ |
| 25 | python3-pluggy \ |
| 26 | python3-pyproject-api \ |
| 27 | python3-tomli \ |
| 28 | python3-virtualenv \ |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 29 | " |
| 30 | |
| 31 | # Install all built-in python3 modules, as the software tested with tox might |
| 32 | # depend on it. Tox will attempt to install all required dependencies |
| 33 | # in a virtualenv using pip, but this obviously does not include the built-in modules. |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 34 | RDEPENDS:${PN} += "python3-modules" |