blob: e7cc6a1699ce50cf1832adf875294813a87a2e08 [file] [log] [blame]
Patrick Williams2390b1b2022-11-03 13:47:49 -05001SUMMARY = "Low-Level Interface to bzip2 compression library"
Andrew Geissler595f6302022-01-24 19:11:47 +00002DESCRIPTION = ""Compress::Raw::Bzip2" provides an interface to the in-memory \
3compression/uncompression functions from the bzip2 compression library."
Patrick Williams2390b1b2022-11-03 13:47:49 -05004HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Bzip2"
Andrew Geissler595f6302022-01-24 19:11:47 +00005SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00007
Patrick Williams7784c422022-11-17 07:29:11 -06008LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=3cca53585f3090f28fa8401bf1db9179"
Andrew Geissler595f6302022-01-24 19:11:47 +00009
Patrick Williams2390b1b2022-11-03 13:47:49 -050010SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Bzip2-${PV}.tar.gz"
Andrew Geissler595f6302022-01-24 19:11:47 +000011
Patrick Williams7784c422022-11-17 07:29:11 -060012SRC_URI[sha256sum] = "6204b270806d924e124e406faf6bbc715f7bb461dfdbea722042325633be300a"
Andrew Geissler595f6302022-01-24 19:11:47 +000013
14DEPENDS += "bzip2"
15
16S = "${WORKDIR}/Compress-Raw-Bzip2-${PV}"
17
18inherit cpan
19
20export BUILD_BZIP2="0"
21export BZIP2_INCLUDE="-I${STAGING_DIR_HOST}${includedir}"
22
23do_compile() {
24 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
25 cpan_do_compile
26}
27
28BBCLASSEXTEND = "native"