blob: fb4efee42d0959b9bf913fbe5b514d67aca8f392 [file] [log] [blame]
Patrick Williams2390b1b2022-11-03 13:47:49 -05001SUMMARY = "Perl interface to allow reading and writing of compressed data."
2DESCRIPTION = "This distribution provides a Perl interface to allow reading \
3and writing of compressed data created with the zlib and bzip2. \
4\
5IO-Compress supports reading and writing of the following compressed data \
6formats \
7 * bzip2 \
8 * RFC 1950 \
9 * RFC 1951 \
10 * RFC 1952 (i.e. gzip) \
11 * zip \
12"
13HOMEPAGE = "https://metacpan.org/release/IO-Compress"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014SECTION = "libs"
15LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
16
Patrick Williams7784c422022-11-17 07:29:11 -060017LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=00f9580b6984ffc2d5f1dc4cc7c3dfcc"
Andrew Geissler9aee5002022-03-30 16:27:02 +000018
Patrick Williams2390b1b2022-11-03 13:47:49 -050019SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/IO-Compress-${PV}.tar.gz"
Andrew Geissler9aee5002022-03-30 16:27:02 +000020
Patrick Williams7784c422022-11-17 07:29:11 -060021SRC_URI[sha256sum] = "f6c55c4e39cfaa3219965dd3b36c9de1edee9a82a10a9cadeb3b74a9ceeeaaad"
Andrew Geissler9aee5002022-03-30 16:27:02 +000022
23S = "${WORKDIR}/IO-Compress-${PV}"
24
25inherit cpan
26
Patrick Williams2390b1b2022-11-03 13:47:49 -050027RDEPENDS:${PN} += "\
28 perl-module-bytes \
29 perl-module-cwd \
30 perl-module-encode \
31 perl-module-file-glob \
32 perl-module-file-spec \
33 perl-module-posix \
34 perl-module-scalar-util \
Patrick Williams7784c422022-11-17 07:29:11 -060035 perl-module-time-local \
Patrick Williams2390b1b2022-11-03 13:47:49 -050036 perl-module-utf8 \
37 libcompress-raw-bzip2-perl \
38 libcompress-raw-zlib-perl \
39"
40
Andrew Geissler9aee5002022-03-30 16:27:02 +000041BBCLASSEXTEND = "native"