blob: 59db7b1d78ac5598ed0a86c3e236d04d79267735 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Tool to produce a statistics based on a diff"
2DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
3the insertions, deletions, and modifications per-file. It is useful for \
4reviewing large, complex patch files."
5HOMEPAGE = "http://invisible-island.net/diffstat/"
6SECTION = "devel"
7LICENSE = "MIT"
Patrick Williams7784c422022-11-17 07:29:11 -06008LIC_FILES_CHKSUM = "file://COPYING;md5=6450594049f0eed1052e634ddcbeec28"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
11 file://run-ptest \
12 file://avoid-check-user-break-cc.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 "
14
Patrick Williams7784c422022-11-17 07:29:11 -060015SRC_URI[sha256sum] = "8cf27424926debcd85921755c3915559288244bd103f62d740dc6b83b557a28a"
Andrew Geissler706d5aa2021-02-12 15:55:30 -060016
Andrew Geissler82c905d2020-04-13 13:39:40 -050017inherit autotools gettext ptest
18
19EXTRA_AUTORECONF += "--exclude=aclocal"
20
21LDFLAGS += "${TOOLCHAIN_OPTIONS}"
22
23do_install_ptest() {
24 cp -r ${S}/testing ${D}${PTEST_PATH}
25}
Andrew Geissler6ce62a22020-11-30 19:58:47 -060026
27BBCLASSEXTEND = "nativesdk"