blob: d26d7f581ac2a0f67daa58184185c6baca31afcd [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Pixman: Pixel Manipulation library"
Brad Bishopc342db32019-05-15 21:57:59 -04002DESCRIPTION = "Pixman provides a library for manipulating pixel regions \
3-- a set of Y-X banded rectangles, image compositing using the \
4Porter/Duff model and implicit mask generation for geometric primitives \
5including trapezoids, triangles, and rectangles."
Andrew Geissler82c905d2020-04-13 13:39:40 -05006HOMEPAGE = "http://www.pixman.org"
7SECTION = "x11/libs"
8DEPENDS = "zlib"
Brad Bishopc342db32019-05-15 21:57:59 -04009
Andrew Geissler82c905d2020-04-13 13:39:40 -050010SRC_URI = "https://www.cairographics.org/releases/${BP}.tar.gz \
11 file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050012 "
Patrick Williams7784c422022-11-17 07:29:11 -060013SRC_URI[sha256sum] = "ea1480efada2fd948bc75366f7c349e1c96d3297d09a3fe62626e38e234a625e"
Brad Bishopc342db32019-05-15 21:57:59 -040014
15# see http://cairographics.org/releases/ - only even minor versions are stable
16UPSTREAM_CHECK_REGEX = "pixman-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)"
17
Andrew Geissler82c905d2020-04-13 13:39:40 -050018PE = "1"
19
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000020LICENSE = "MIT & MIT & PD"
Brad Bishopc342db32019-05-15 21:57:59 -040021LIC_FILES_CHKSUM = "file://COPYING;md5=14096c769ae0cbb5fcb94ec468be11b3 \
22 file://pixman/pixman-matrix.c;endline=21;md5=4a018dff3e4e25302724c88ff95c2456 \
23 file://pixman/pixman-arm-neon-asm.h;endline=24;md5=9a9cc1e51abbf1da58f4d9528ec9d49b \
24 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050025
26inherit meson pkgconfig
27
28# These are for the tests and demos, which we don't install
29EXTRA_OEMESON = "-Dgtk=disabled -Dlibpng=disabled"
30# ld: pixman/libpixman-mmx.a(pixman-mmx.c.o):
31# linking mips:loongson_2f module with previous mips:isa64 modules
32EXTRA_OEMESON += "-Dloongson-mmi=disabled"
Patrick Williams213cb262021-08-07 19:21:33 -050033# disable iwmmxt due to compile fails on most arm platforms.
34EXTRA_OEMESON += "-Diwmmxt=disabled"
Andrew Geissler82c905d2020-04-13 13:39:40 -050035
Patrick Williams0ca19cc2021-08-16 14:03:13 -050036EXTRA_OEMESON:append:class-target:powerpc = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "-Dvmx=enabled", "-Dvmx=disabled", d)}"
37EXTRA_OEMESON:append:class-target:powerpc64 = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "-Dvmx=enabled", "-Dvmx=disabled", d)}"
38EXTRA_OEMESON:append:class-target:powerpc64le = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "-Dvmx=enabled", "-Dvmx=disabled", d)}"
39
Brad Bishopc342db32019-05-15 21:57:59 -040040BBCLASSEXTEND = "native nativesdk"