blob: ccfe2777466d80b966b412c514f1dd320c799eda [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Pixman: Pixel Manipulation library"
Brad Bishopc342db32019-05-15 21:57:59 -04002DESCRIPTION = "Pixman provides a library for manipulating pixel regions \
3-- a set of Y-X banded rectangles, image compositing using the \
4Porter/Duff model and implicit mask generation for geometric primitives \
5including trapezoids, triangles, and rectangles."
Andrew Geissler82c905d2020-04-13 13:39:40 -05006HOMEPAGE = "http://www.pixman.org"
7SECTION = "x11/libs"
8DEPENDS = "zlib"
Brad Bishopc342db32019-05-15 21:57:59 -04009
Andrew Geissler82c905d2020-04-13 13:39:40 -050010SRC_URI = "https://www.cairographics.org/releases/${BP}.tar.gz \
11 file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050012 "
Andrew Geissler4ed12e12020-06-05 18:00:41 -050013SRC_URI[md5sum] = "73858c0862dd9896fb5f62ae267084a4"
14SRC_URI[sha256sum] = "6d200dec3740d9ec4ec8d1180e25779c00bc749f94278c8b9021f5534db223fc"
Brad Bishopc342db32019-05-15 21:57:59 -040015
16# see http://cairographics.org/releases/ - only even minor versions are stable
17UPSTREAM_CHECK_REGEX = "pixman-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)"
18
Andrew Geissler82c905d2020-04-13 13:39:40 -050019PE = "1"
20
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000021LICENSE = "MIT & MIT & PD"
Brad Bishopc342db32019-05-15 21:57:59 -040022LIC_FILES_CHKSUM = "file://COPYING;md5=14096c769ae0cbb5fcb94ec468be11b3 \
23 file://pixman/pixman-matrix.c;endline=21;md5=4a018dff3e4e25302724c88ff95c2456 \
24 file://pixman/pixman-arm-neon-asm.h;endline=24;md5=9a9cc1e51abbf1da58f4d9528ec9d49b \
25 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27inherit meson pkgconfig
28
29# These are for the tests and demos, which we don't install
30EXTRA_OEMESON = "-Dgtk=disabled -Dlibpng=disabled"
31# ld: pixman/libpixman-mmx.a(pixman-mmx.c.o):
32# linking mips:loongson_2f module with previous mips:isa64 modules
33EXTRA_OEMESON += "-Dloongson-mmi=disabled"
Patrick Williams213cb262021-08-07 19:21:33 -050034# disable iwmmxt due to compile fails on most arm platforms.
35EXTRA_OEMESON += "-Diwmmxt=disabled"
Andrew Geissler82c905d2020-04-13 13:39:40 -050036
Patrick Williams0ca19cc2021-08-16 14:03:13 -050037EXTRA_OEMESON:append:class-target:powerpc = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "-Dvmx=enabled", "-Dvmx=disabled", d)}"
38EXTRA_OEMESON:append:class-target:powerpc64 = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "-Dvmx=enabled", "-Dvmx=disabled", d)}"
39EXTRA_OEMESON:append:class-target:powerpc64le = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "-Dvmx=enabled", "-Dvmx=disabled", d)}"
40
Brad Bishopc342db32019-05-15 21:57:59 -040041BBCLASSEXTEND = "native nativesdk"