blob: 9f7ce9c570849a4d2af0b69df5b0f63e60b3bff7 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A shared storage lock manager"
2DESCRIPTION = "sanlock is a lock manager built on shared storage. Hosts with access \
3to the storage can perform locking. An application running on the \
4hosts is given a small amount of space on the shared block device or \
5file, and uses sanlock for its own application-specific synchronization. \
6Internally, the sanlock daemon manages locks using two disk-based \
7lease algorithms: delta leases and paxos leases."
8HOMEPAGE = "https://pagure.io/sanlock"
9SECTION = "utils"
10
11LICENSE = "LGPLv2+ & GPLv2 & GPLv2+"
12LIC_FILES_CHKSUM = "file://README.license;md5=60487bf0bf429d6b5aa72b6d37a0eb22"
13
Brad Bishop779d0ac2019-09-27 08:23:48 -040014SRC_URI = "git://pagure.io/sanlock.git;protocol=http"
15SRCREV = "7afe0e66f5c7f24894896fad20ffa6f39733d80f"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016S = "${WORKDIR}/git"
17
18DEPENDS = "libaio util-linux"
19
20inherit distutils
21
22do_configure[noexec] = "1"
23
24do_compile_prepend () {
25 oe_runmake -C wdmd CMD_LDFLAGS="${LDFLAGS}" LIB_LDFLAGS="${LDFLAGS}"
26 oe_runmake -C src CMD_LDFLAGS="${LDFLAGS}" LIB_ENTIRE_LDFLAGS="${LDFLAGS}" LIB_CLIENT_LDFLAGS="${LDFLAGS}"
27 cd ${S}/python
28}
29
30do_install_prepend () {
31 oe_runmake -C wdmd DESTDIR=${D} LIBDIR=${libdir} install
32 oe_runmake -C src DESTDIR=${D} LIBDIR=${libdir} install
33 cd ${S}/python
34}