blob: a244767450dbc7f562e9ea58682e24f52d72790a [file] [log] [blame]
Matt Spinlera48f7f62018-06-21 13:13:52 -05001SUMMARY = "Copy error yaml files to known path for elog parsing"
2PR = "r1"
Patrick Venture9ea4aaf2018-10-24 12:55:20 -07003PV = "1.0+git${SRCPV}"
Matt Spinlera48f7f62018-06-21 13:13:52 -05004LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Matt Spinlera48f7f62018-06-21 13:13:52 -05006
7inherit native
8inherit phosphor-dbus-yaml
9
10require phosphor-led-manager.inc
11
12S = "${WORKDIR}/git"
13
14do_install_append() {
15 SRC=${S}/xyz/openbmc_project/Led/
16 DEST=${D}${yaml_dir}/xyz/openbmc_project/Led/
17 install -d ${DEST}/Fru
18 install ${SRC}/*.errors.yaml ${DEST}
19 install ${SRC}/*.metadata.yaml ${DEST}
20 install ${SRC}/Fru/*.errors.yaml ${DEST}/Fru
21 install ${SRC}/Fru/*.metadata.yaml ${DEST}/Fru
22}