blob: 8e3718102e3f5cee7c5f17493617a1166c93ffcc [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Improved drop-in replacement for std::function"
2DESCRIPTION = "Provides improved implementations of std::function."
3HOMEPAGE = "https://naios.github.io/function2"
4LICENSE = "BSL-1.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
Andrew Geissler78b72792022-06-14 06:47:25 -05006SRCREV = "f569a63cfe369df867a1a4d17aaa12269156536c"
Brad Bishop19323692019-04-05 15:28:33 -04007PV .= "+git${SRCPV}"
8
Andrew Geissler595f6302022-01-24 19:11:47 +00009SRC_URI += "gitsm://github.com/Naios/function2;branch=master;protocol=https"
Brad Bishop19323692019-04-05 15:28:33 -040010
11S = "${WORKDIR}/git"
12
13inherit cmake
14inherit ptest
15
16# Installs some data to incorrect top-level /usr directory
Patrick Williams213cb262021-08-07 19:21:33 -050017do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040018 mkdir -p ${D}/${datadir}/function2
19 mv ${D}/${prefix}/Readme.md ${D}/${datadir}/function2/
20 mv ${D}/${prefix}/LICENSE.txt ${D}/${datadir}/function2/
21}