blob: f4a014e171a8401475968bef53dddfed5927f3bc [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Linux system security checks"
2DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used."
3SECTION = "security"
Andrew Geissler5199d832021-09-24 16:47:35 -05004LICENSE = "BSD-3-Clause"
Brad Bishop19323692019-04-05 15:28:33 -04005HOMEPAGE="https://github.com/slimm609/checksec.sh"
6
Andrew Geissler78b72792022-06-14 06:47:25 -05007LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=879b2147c754bc040c29e9c3b84da836"
Brad Bishop19323692019-04-05 15:28:33 -04008
Andrew Geissler78b72792022-06-14 06:47:25 -05009SRCREV = "2753ebb89fcdc96433ae8a4c4e5a49214a845be2"
10SRC_URI = "git://github.com/slimm609/checksec.sh;branch=main;protocol=https"
Brad Bishop19323692019-04-05 15:28:33 -040011
12S = "${WORKDIR}/git"
13
14do_install() {
15 install -d ${D}${bindir}
16 install -m 0755 ${S}/checksec ${D}${bindir}
17}
18
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN} = "bash openssl-bin binutils"
Andrew Geissler78b72792022-06-14 06:47:25 -050020
21BBCLASSEXTEND = "native"