blob: 89495ecc7c43d4252c12df5c550f6cf495f3a39d [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "File type identification using libmagic"
2DESCRIPTION = "This module uses ctypes to access the libmagic file type \
3 identification library. It makes use of the local magic database and supports \
4 both textual and MIME-type output."
5HOMEPAGE = "http://github.com/ahupp/python-magic"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=61495c152d794e6be5799a9edca149e3"
9
10PYPI_PACKAGE = "python-magic"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011
12inherit pypi setuptools3
13
Andrew Geissler78b72792022-06-14 06:47:25 -050014SRC_URI[sha256sum] = "8262c13001f904ad5b724d38b5e5b5f17ec0450ae249def398a62e4e33108a50"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000015
16RDEPENDS:${PN} += "file \
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-io \
19 ${PYTHON_PN}-logging \
20 ${PYTHON_PN}-shell"
21
22BBCLASSEXTEND = "native"