blob: 84df1a16c1c7d3ffda4ea3961dfc024b6ccc5712 [file] [log] [blame]
Potin Laieb37b942023-02-08 13:25:38 +08001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3inherit obmc-phosphor-systemd
4
5SRC_URI:append:bletchley = " \
6 file://nvme-json-rewrite \
7 file://nvme-json-rewrite.conf \
Delphine CC Chiu796196a2023-06-27 13:48:55 +08008 file://nvme_config.json \
Potin Laieb37b942023-02-08 13:25:38 +08009"
10
11RDEPENDS:${PN}:bletchley += "bash"
12
13do_install:append:bletchley() {
14 install -d ${D}${libexecdir}/${PN}/
15 install -m 0755 ${WORKDIR}/nvme-json-rewrite ${D}${libexecdir}/${PN}/
Delphine CC Chiu796196a2023-06-27 13:48:55 +080016
17 install -d ${D}${sysconfdir}/nvme
18 install -m 0644 -D ${WORKDIR}/nvme_config.json ${D}${sysconfdir}/nvme
Potin Laieb37b942023-02-08 13:25:38 +080019}
20
21SYSTEMD_OVERRIDE:${PN}:append:bletchley = " \
22 nvme-json-rewrite.conf:xyz.openbmc_project.nvme.manager.service.d/nvme-json-rewrite.conf \
23"