blob: 742c9a5cf2df1e60a5cce1814c0e971e9746e90d [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenPrinting printer support - filters"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "https://wiki.linuxfoundation.org/openprinting/start"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003DESCRIPTION = "Foomatic is a printer database designed to make it easier to set up \
4common printers for use with UNIX-like operating systems.\
5It provides the "glue" between a print spooler (like CUPS or lpr) and \
6the printer, by processing files sent to the printer. \
7 \
8This package consists of filters used by the printer spoolers \
9to convert the incoming PostScript data into the printer's native \
10format using a printer-specific, but spooler-independent PPD file. \
11"
12
13DEPENDS += "cups perl libxml2"
14PR = "r1"
15
16LICENSE = "GPLv2+"
17LIC_FILES_CHKSUM = "file://${WORKDIR}/foomatic-filters-${PV}/COPYING;md5=393a5ca445f6965873eca0259a17f833"
18
19SRC_URI = "http://www.openprinting.org/download/foomatic/foomatic-filters-${PV}.tar.gz"
20
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021SRC_URI += "file://CVE-2015-8560.patch \
22 file://CVE-2015-8327.patch \
23 "
24
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025SRC_URI[md5sum] = "b05f5dcbfe359f198eef3df5b283d896"
26SRC_URI[sha256sum] = "a2e2e53e502571e88eeb9010c45a0d54671f15707ee104f5c9c22b59ea7a33e3"
27
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050028UPSTREAM_CHECK_REGEX = "foomatic-filters-(?P<pver>((\d|\d\d)\.*)+)\.tar\.gz"
29
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030inherit autotools pkgconfig
31
32EXTRA_OECONF += "--disable-file-converter-check --with-file-converter=texttops"
33
34do_configure_prepend() {
35 export PERL="${bindir}/env perl"
36 export CUPS_SERVERBIN=${exec_prefix}/lib/cups # /usr/lib NOT libdir
37}
38
39do_install_append_linuxstdbase() {
40 install -d ${D}${exec_prefix}/lib/cups/filter
41 ln -sf ${bindir}/foomatic-rip ${D}${exec_prefix}/lib/cups/filter
42}
43
44FILES_${PN} += "${exec_prefix}/lib/cups/ ${exec_prefix}/lib/ppr/"