blob: c847b6d7bbbc08cd3cc357502637912e8bff5991 [file] [log] [blame]
Marri Devender Rao09a8ceb2018-10-09 07:53:30 -05001SUMMARY = "Phosphor certificate manager configuration for an nslcd authority service"
2
3PR = "r1"
4
5LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04006LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Marri Devender Rao09a8ceb2018-10-09 07:53:30 -05007
Patrick Williams12fc9392021-08-06 09:16:53 -05008RDEPENDS:${PN} = "phosphor-certificate-manager"
Marri Devender Rao09a8ceb2018-10-09 07:53:30 -05009
10inherit allarch
Marri Devender Rao09a8ceb2018-10-09 07:53:30 -050011
Brad Bishop4eceffc2019-03-21 19:08:15 -040012SRC_URI = "file://env"
13
Patrick Williams12fc9392021-08-06 09:16:53 -050014FILES:${PN} = "${datadir}"
Zbigniew Kurzynski84017022019-10-10 12:39:21 +020015
Brad Bishop4eceffc2019-03-21 19:08:15 -040016do_install() {
Zbigniew Kurzynski84017022019-10-10 12:39:21 +020017 install -D ${WORKDIR}/env ${D}/${datadir}/phosphor-certificate-manager/authority
Brad Bishop4eceffc2019-03-21 19:08:15 -040018}
19
Patrick Williams12fc9392021-08-06 09:16:53 -050020pkg_postinst:${PN}() {
Brad Bishop4eceffc2019-03-21 19:08:15 -040021 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@authority.service"
22 TARGET="../phosphor-certificate-manager@.service"
23 mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
24 ln -s $TARGET $LINK
25}
26
Patrick Williams12fc9392021-08-06 09:16:53 -050027pkg_prerm:${PN}() {
Brad Bishop4eceffc2019-03-21 19:08:15 -040028 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@authority.service"
29 rm $LINK
30}