blob: fe3630a981ea69025e526d51fde3e0bfcd939a95 [file] [log] [blame]
Jayanth Othayothc9385132021-06-21 07:21:14 -05001HOMEPAGE = "https://github.com/open-power/libekb_p10"
2
3SUMMARY = "Hardware Procedure Framework"
4DESCRIPTION = "Provides infrastructure to run hardware procedures"
5PR = "r1"
6PV = "1.0+git${SRCPV}"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10S = "${WORKDIR}/git"
11
12require recipes-bsp/ekb/ekb.inc
13
14inherit autotools \
15 python3native \
16 perlnative
17
18SRCREV_FORMAT = "libekb_ekb"
19
Jayanth Othayoth7bad6932021-11-16 22:44:31 -060020SRCREV_libekb = "c1d1ff7f1559d6cf2c6c1eda99a9133b4157d63b"
Jayanth Othayothc9385132021-06-21 07:21:14 -050021SRCREV_ekb = "${EKB_REV}"
22
23SRC_URI = "git://git@github.com/open-power/libekb_p10;branch="main";name=libekb \
24 ${EKB_URI};name=ekb;destsuffix=git/ekb \
25 "
26
27DEPENDS = "pdbg libxml-simple-perl-native"