Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "A system tool for maintaining the /etc/rc*.d hierarchy" |
| 2 | DESCRIPTION = "Chkconfig is a basic system utility. It updates and queries runlevel \ |
| 3 | information for system services. Chkconfig manipulates the numerous \ |
| 4 | symbolic links in /etc/rc.d, to relieve system administrators of some \ |
| 5 | of the drudgery of manually editing the symbolic links." |
| 6 | |
| 7 | RECIPE_NO_UPDATE_REASON = "Version 1.5 requires selinux" |
| 8 | |
Brad Bishop | 37a0e4d | 2017-12-04 01:01:44 -0500 | [diff] [blame] | 9 | HOMEPAGE = "https://github.com/fedora-sysv" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | |
| 11 | LICENSE = "GPLv2" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018" |
| 13 | |
| 14 | DEPENDS = "libnewt popt" |
| 15 | PROVIDES += "virtual/update-alternatives" |
| 16 | |
| 17 | PR = "r7" |
| 18 | |
Brad Bishop | 37a0e4d | 2017-12-04 01:01:44 -0500 | [diff] [blame] | 19 | S = "${WORKDIR}/${BPN}-${BPN}-${PV}" |
| 20 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 21 | SRC_URI = "git://github.com/fedora-sysv/chkconfig.git \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 22 | file://replace_caddr_t.patch \ |
| 23 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 24 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 25 | SRCREV = "3e0b3909ff6328d232b27b9c32f1a9309c6cd0a4" |
| 26 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" |
| 27 | |
| 28 | S = "${WORKDIR}/git" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 29 | |
| 30 | inherit gettext |
| 31 | |
| 32 | # Makefile uses RPM_OPT_FLAGS to construct CFLAGS |
| 33 | # |
| 34 | EXTRA_OEMAKE = "\ |
| 35 | 'RPM_OPT_FLAGS=${CFLAGS}' \ |
| 36 | 'LDFLAGS=${LDFLAGS}' \ |
| 37 | 'BINDIR=${base_sbindir}' \ |
| 38 | 'SBINDIR=${sbindir}' \ |
| 39 | 'MANDIR=${mandir}' \ |
| 40 | 'ALTDIR=${localstatedir}/lib/alternatives' \ |
| 41 | 'ALTDATADIR=${sysconfdir}/alternatives' \ |
| 42 | " |
| 43 | |
| 44 | do_unpack[postfuncs] += "obey_variables" |
| 45 | do_unpack[vardeps] += "obey_variables" |
| 46 | obey_variables () { |
| 47 | sed -i -e 's,/etc,${sysconfdir},; s,/lib/systemd,${base_libdir}/systemd,' ${S}/leveldb.h |
| 48 | sed -i -e 's,/etc/alternatives,${sysconfdir}/alternatives,' \ |
| 49 | -e 's,/var/lib/alternatives,${localstatedir}/lib/alternatives,' \ |
| 50 | -e 's,/usr/share/locale,${datadir}/locale,' ${S}/alternatives.c |
| 51 | } |
| 52 | |
| 53 | do_install() { |
| 54 | oe_runmake 'DESTDIR=${D}' 'INSTALLNLSDIR=${D}${datadir}/locale' \ |
| 55 | 'BINDIR=${sbindir}' install |
| 56 | install -d ${D}${sysconfdir}/chkconfig.d |
| 57 | } |
| 58 | |
| 59 | PACKAGES =+ "${PN}-alternatives ${PN}-alternatives-doc" |
| 60 | SUMMARY_${PN}-alternatives = "Maintain symbolic links determining default commands" |
| 61 | DESCRIPTION_${PN}-alternatives = "alternatives creates, removes, maintains and displays \ |
| 62 | information about the symbolic links comprising the alternatives system." |
| 63 | SUMMARY_${PN}-alternatives-doc = "${SUMMARY_${PN}-alternatives} - Documentation files" |
| 64 | DESCRIPTION_${PN}-alternatives-doc = "${DESCRIPTION_${PN}-alternatives} \ |
| 65 | This package contains documentation." |
| 66 | RPROVIDES_${PN}-alternatives += "update-alternatives" |
| 67 | RCONFLICTS_${PN}-alternatives = "update-alternatives-opkg update-alternatives-dpkg" |
| 68 | FILES_${PN}-alternatives = "${sbindir}/alternatives ${sbindir}/update-alternatives \ |
| 69 | ${sysconfdir}/alternatives ${localstatedir}/lib/alternatives" |
| 70 | FILES_${PN}-alternatives-doc = "${mandir}/man8/alternatives.8 \ |
| 71 | ${mandir}/man8/update-alternatives.8" |