Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Convert text file line endings between CRLF and LF" |
| 2 | DESCRIPTION = "The Dos2unix package includes utilities dos2unix and \ |
| 3 | unix2dos to convert plain text files in DOS or Mac format to Unix \ |
| 4 | format and vice versa." |
| 5 | HOMEPAGE = "http://waterlan.home.xs4all.nl/dos2unix.html" |
| 6 | SECTION = "support" |
| 7 | |
| 8 | LICENSE = "BSD-2-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=1b78fca784db24f4a40e30b300787f3f" |
| 10 | |
| 11 | SRC_URI = "git://git.code.sf.net/p/dos2unix/dos2unix" |
| 12 | UPSTREAM_CHECK_GITTAGREGEX = "dos2unix-(?P<pver>(\d+(\.\d+)+))" |
| 13 | |
| 14 | # Release 7.4.0 |
| 15 | SRCREV = "1182533bde3c1fe65be2ead465e87671faa2c027" |
| 16 | |
| 17 | S = "${WORKDIR}/git/dos2unix" |
| 18 | |
| 19 | inherit gettext perlnative |
| 20 | |
| 21 | # The dos2unix NLS relies on po4a-native, while po4a recipe is |
| 22 | # provided by meta-perl layer, so make it optional here, you |
| 23 | # need have meta-perl in bblayers.conf before enabling nls in |
| 24 | # PACKAGECONFIG. |
| 25 | PACKAGECONFIG ??= "" |
| 26 | PACKAGECONFIG[nls] = "ENABLE_NLS=1,ENABLE_NLS=,po4a-native" |
| 27 | |
| 28 | EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} LDFLAGS_USER='${LDFLAGS}'" |
| 29 | EXTRA_OEMAKE_class-native = "ENABLE_NLS=" |
| 30 | |
| 31 | do_install () { |
| 32 | oe_runmake DESTDIR="${D}${base_prefix}" install |
| 33 | } |
| 34 | |
| 35 | BBCLASSEXTEND = "native nativesdk" |