blob: 40ac1a890ff974eeaab30b96cec76f4fcbfe28d6 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3SECTION = "security"
4LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
6
Andrew Geisslerb2fe8632020-08-21 15:57:21 -05007DEPENDS += "gperf-native"
Brad Bishopc342db32019-05-15 21:57:59 -04008
Andrew Geissler8b139282021-03-05 15:22:30 -06009SRCREV = "4bf70431a339a2886ab8c82e9a45378f30c6e6c7"
Andrew Geisslerb2fe8632020-08-21 15:57:21 -050010
11SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.5 \
Brad Bishopc342db32019-05-15 21:57:59 -040012 file://run-ptest \
Andrew Geissler8b139282021-03-05 15:22:30 -060013 "
Brad Bishopc342db32019-05-15 21:57:59 -040014
Andrew Geisslerb2fe8632020-08-21 15:57:21 -050015COMPATIBLE_HOST_riscv32 = "null"
16
Brad Bishopc342db32019-05-15 21:57:59 -040017S = "${WORKDIR}/git"
18
19inherit autotools-brokensep pkgconfig ptest
20
21PACKAGECONFIG ??= ""
Andrew Geisslerb2fe8632020-08-21 15:57:21 -050022PACKAGECONFIG[python] = "--enable-python, --disable-python, python3"
Brad Bishopc342db32019-05-15 21:57:59 -040023
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040024DISABLE_STATIC = ""
25
Brad Bishopc342db32019-05-15 21:57:59 -040026do_compile_ptest() {
27 oe_runmake -C tests check-build
28}
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests
32 install -d ${D}${PTEST_PATH}/tools
33 for file in $(find tests/* -executable -type f); do
34 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
35 done
36 for file in $(find tests/*.tests -type f); do
37 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
38 done
39 for file in $(find tools/* -executable -type f); do
40 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
41 done
42}
43
44FILES_${PN} = "${bindir} ${libdir}/${BPN}.so*"
45FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
46
Andrew Geisslerd1d22e62020-10-16 10:14:32 -050047RDEPENDS_${PN}-ptest = "coreutils bash"